"File Symbols" (Ctrl + R) do not work any longer


#1

Hi,
when I try to use Packages / Symbols / File Symbols (Ctrl + R) Atom works for a while (“Generating symbols” appears in the small window on the top) and then it shows in the same window “No symbols found”.
It worked before, not sure what has changed.
Even listing of project-wide symbols (Ctrl + Shift + R) worked (with the help of the ctags tool) and Go to Decleration F12 (sometimes) worked too, but no longer.

Any idea what I can do to get that functionality back?

WIN 7
Atom 1.32.2 X64
Working mainly with C-langugae
Packages: atom-ctags, atom-id-ui, ide-cpp (I listed only the ones where I see a relation to the issue)

Thank you.

Christian


#2

Does toggling Settings -> Core -> Use Tree Sitter Parsers fix it?

I’m not sure if that’s supported by them yet, and is the most likely thing that’s changed (it was enabled by default recently).


#3

No, unfortunately there is noch change in behaviour, no difference with Settings -> Core -> Use Tree Sitter Parserschecked or not.