File chartset encoding auto-detect doesnt work


#1

Hello,
I just start using ATOM IDE, We use Central Europe ISO-8859-2 chartset encoding of our files,
I used autodetect in PSPAD in the past, but I wanted to move to ATOM editor.
It detects ISO-8859-2 files as UTF-8.

If I create brand new file from scratch with hello world and I set in the bottom right,
that the file is ISO-8859-2 and I also set in header of html structure,
I save the file and reopen it, it detects it as UTF-8 not ISO.

It is hard to use the editor for me, if autodetect is not working, but what is more dangerous,
if I set it manually to some encoding and save the file, it changes all the special characters to some different
and it destroy the special characters in the file, so I cannot risk it to break any files of our system.

Is there any update / solution / settings, how to get it work properly?