Few small questions


#1

When using “toggle comments” on multiple lines after 1st and before 2nd commenting symbolSets additional spaces added (ex.: was: /*test*/ ; now: /* test */)
Is it atom side, if no: what can be the reason;, how to disable it?
also when trying to fold with cursor at last line before the foldable’s end it do not folding properly fol


#2

Atom comment toggling only does line comments I think, are you using a community package for toggling block comments?

also when trying to fold with cursor at last line before the foldable’s end it do not folding properly fol

Can you share copy and paste the code you’re trying to fold and let us know exactly where you try to fold and what the incorrect folding looks like?


#3

No, it definitely commenting selected lines by block comments, check if in language package you using is correctly written the block comment symbolSets
Anything (https://yadi.sk/i/Axi9X5wJ3Qnb3d (fold at mark, on my side it folding “te”, what is incorrect))


#4

No, it devinitely commenting selected lines by block comments, check if in language package you using is correctly written the block comment symbolSets

What language package are you using?

Anything (https://yadi.sk/i/Axi9X5wJ3Qnb3d1 (fold at mark, on my side it folding “te”, what is incorrect))

Can you share the code directly here? Just add it in a code block like this:

```javascript
for (var i = 0; i < 10; i++) {
  if (true) {
    console.log("true");
  } else {
    console.log("false");
  }
}
 ```

And then let us know which specific line you fold?


#5

Language-arma-atom,
te
/tab slak
/tab /tab ds
/tab /tab ds //fold here;
/tab s
te
(tryed to make it “code” but it didn’t worked)


#6

Thanks :+1: I poked around a bit and it looks like the whitespace padding is intentional:

There’s no config that let’s you adjust this as far as I know but there are some packages around that might support this e.g. https://atom.io/packages/sublime-block-comment.

Can you share a screencast of this behavior? With this text, I don’t have the option to fold at line 4, only at line 1 and 2:

te
	slak
		ds
		ds	//fold here;
	s
te

What I see:

folds


#7

Thanks for answer on commenting,


#8

any ideas ?


#9

Can you share that exact code here so I can try that? Or if you can share the smallest amount of code that will reproduce the issue you’re describing and then point out the exact line number where you’re folding, that would be most helpful when trying to reproduce.


#10

are you kidding me?
that on 100% doesn’t matter what is written, atom folding based on tabs and nothing else


#11

I’m doing my best to help but some things aren’t clear to me from your description - for example, I showed that from this text that you shared initially:

te
	slak
		ds
		ds	//fold here;
	s
te

I see this:

no-fold

You mentioned to fold at line 4, but my image shows that I don’t have a fold option at line 4.

So either I’m mis-understanding (which is definitely possible), I don’t have the right content to try and reproduce, or something else.

I’m happy to keep trying to help if you’d like to share the details that I asked for, or maybe someone else can jump in that spots what I’m missing/mis-understanding.


#12

Use hotkey (ctrl+shft+[)


#13

damn, (ctrl+alt+[), sor


#14

Ahhh ok, I think I see what you’re saying now? With this text:

te
	slak
		ds
		ds	//fold here;
	s
te

Folding at line 4 with Editor: Fold Current Row, it folds like this:

fold-1

But it should fold like this:

fold-2

Is that right?


#15

correct

(characters limit weird)


#16

Thanks I’ll go ahead and open an issue for this.


#17

#18

“When using “toggle comments” on multiple lines after 1st and before 2nd commenting symbolSets additional spaces added (ex.: was: /*test*/; now: /* test */);”

answer: https://github.com/ValentinLaTortue/quick-comment