Fetching packages fails on OSX


#1

New fresh install 0.115.0 on OSX.

Getting an error when trying to browse for packages.

➜  ~  sw_vers  
ProductName:	Mac OS X
ProductVersion:	10.9.4
BuildVersion:	13E28

➜  ~  xcodebuild -version
Xcode 5.1.1
Build version 5B1008

➜  ~  node --version     
v0.10.29

#2

bump, I still cant figure it out


#3

The commands that it is saying it can’t find, dirname and basename, are built-in commands. I’m not sure how your system could be in a state where those are not accessible. The only thing that I can think of is that somehow /usr/bin is not in your PATH?


#4
deini$ echo $PATH
/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin

:cry:


#5

Whoops … sorry I missed this the first few times I looked … :cry:

Atom expects to be installed in /Applications unless you set an environment variable ATOM_PATH, I think. You’re running Atom from ~/Downloads:

If you copy it to /Applications, things should work fine.


#6

I know it’s a bit late, but I was having the same problem today and you seem to be the only one with my exact problem. I ended up reading something about how atom/osx handles the path differently through spotlight/finder. When I open the application that way I receive the same problem you have, but if I open atom through the terminal (just type atom) everything works perfectly. I’m working on a better solution, but for now I’m happy, hope it helps!


#7

Same here. all is well if launched from command line. Otherwise, errors galore.


#8

Hm. I’m also getting a package fetch error under OS X (Requesting packages failed: Application error). Happens whether I start from LaunchBar or Terminal. Version 0.199.0. Atom is installed in /Applications.


#9

@gtcaz Are you behind a proxy? If so, you may want to take a look here:


#10

@leedohm Nope no proxy. Still not working today, so doesn’t seem transient. Looks like it’s just the featured packages section, though. Thanks!


#11

@leedohm Never mind — 0.200.0 seems to have fixed it!


#12

I’m having the same problem for a different reason:

gyp info it worked if it ends with ok
gyp info using node-gyp@3.4.0
gyp info using node@4.4.5 | darwin | x64
gyp http GET https://atom.io/download/atom-shell/v0.37.8/node-v0.37.8.tar.gz
gyp WARN install got an error, rolling back install
gyp ERR! install error
gyp ERR! stack Error: socket hang up
gyp ERR! stack at createHangUpError (_http_client.js:211:15)
gyp ERR! stack at Socket.socketOnEnd (_http_client.js:303:23)
gyp ERR! stack at emitNone (events.js:72:20)
gyp ERR! stack at Socket.emit (events.js:166:7)
gyp ERR! stack at endReadableNT (_stream_readable.js:913:12)
gyp ERR! stack at nextTickCallbackWith2Args (node.js:442:9)
gyp ERR! stack at process._tickCallback (node.js:356:17)
gyp ERR! System Darwin 15.6.0
gyp ERR! command “/Applications/Atom.app/Contents/Resources/app/apm/bin/node” “/Applications/Atom.app/Contents/Resources/app/apm/node_modules/node-gyp/bin/node-gyp.js” “install” “–runtime=electron” “–target=0.37.8” “–dist-url=https://atom.io/download/atom-shell” “–arch=x64” "–ensure"
gyp ERR! cwd /Users/THE_ATOMIC_WONDER/.atom
gyp ERR! node -v v4.4.5
gyp ERR! node-gyp -v v3.4.0
gyp ERR! not ok

It happens for every package I try to install.


#13

Are you behind a proxy? It sounds like it is having a problem downloading https://atom.io/download/atom-shell/v0.37.8/node-v0.37.8.tar.gz

If you are behind a proxy, you should check out the Installing Atom section of the Atom Flight Manual:

http://flight-manual.atom.io/getting-started/sections/installing-atom/#proxy-and-firewall-settings


#14

How do I find if I’m using a proxy? I’ve been in the network/proxy settings and I’ve got nothing enabled there. When I go to the link you sent and run “apm config get https-proxy” it returns a Null.


#15

Most corporate environments use a proxy of some kind. You may want to check with IT to find out for sure and the address you need to configure Atom.


#16

I’ll be sure to clarify and my next post, but I’m not at a corporate office. I’m just at home on my local wifi network.

Do I need to go through a proxy? Would it work if I just configure it to localhost.8080?


#17

No, without a proxy is much, much easier.

If you’re not going through a proxy, I’m not sure what would repeatedly cause this error:

gyp ERR! stack Error: socket hang up

“socket hang up” generally indicates there is a network problem or instability. So it could just be network connectivity.

Out of curiosity, what packages are you trying to install?


#18

Thanks - it’s not letting me load either of the packages I’m trying to
install:

autocomplete-python
Atom-runner

Here’s the thing, they both install on my MacPro tower, but not on my
MacBook laptop.
I didn’t think it would work but I just tried it anyway, and now I’m going
to have to try and find the differences.


#19

Can you install something like my tabs-to-spaces package successfully?


#20

No dice. The error starts with this:

npm WARN invalid config https-proxy=""
npm WARN invalid config Must be a full url with ‘http://’

Can I set the proxy in the Terminal to Null, or something else for this to work?