Fetching packages failed!


#1

‘C:\Users’ is not recognized as an internal or external command,
operable program or batch file.

I am using Windows 10. (I’m also quite new at using Atom)

Also, any content that tries to load in “Packages” and “Themes” seems to not display correctly. How can all of this be fixed?


#2

Have you followed the suggestions in the Debugging document? Also, could you give the following information?

  • Which version of Atom are you using?
  • Can you reproduce the issue after completely exiting Atom and restarting using atom --safe?
  • How did you install Atom?
  • Have you tried reinstalling Atom?

#3

I am using Atom Pre-release 1.6.0-beta3.
The issue is the same every time on any version of Atom even with restarting with atom --safe.
I installed Atom with an .exe file on Windows 10.
I have reinstalled Atom many times to try to see if I could somehow fix the issue.

Also, here is some extra info if this is needed.

OS Name: Microsoft Windows 10 Home
Version: 10.0.10586 Build 10586
OS Manufacturer: Microsoft Corporation


#4
  • Did you download Atom from the Atom website? (https://atom.io)
  • Have you tried the production version instead of the beta?

#5

I have used the production version of Atom originally, but it always gives the same result. I switched to the beta versions to see if the problem would not be present.


#6

It appears that there’s something wrong with your installation. I’m not sure what it is because I’ve never seen that error message before. Can you try this:

  1. Close all open instances of Atom
  2. Move or rename the C:\Users\[whatever-your-username-is]\.atom directory
  3. Start Atom again

#7

The error could be coming from a problem with upgrading from Windows 8.1 to Windows 10.
I’m guessing that fixing this error is almost out of my league, so I will go use something else or I might do some research to see if I can fix it…


#8

I assume you followed @leedohm’s advice and it didn’t work. If so try the same thing again but reinstall atom between steps 2 and 3.


#9

The installation worked great, but the error still persists like mark_hahn predicted. Would it prevent the error if “C:\Users” was used instead? Could there be an error in atom’s code that was overlooked? All I ever wanted to do with atom was to install a package for handling Lua, but the error prevents that from happening.


#10

What happens when you try to install it manually using apm? See apm help for a command list; apm install pigments would be the instruction to install the Pigments package.