Fetching featured packages failed. Windows 7


#1

When I try to search for packages I get the following error message:

spawn C:\Windows\system32\cmd.exe;C:\Python27\Scripts ENOENT```

I was previously able to install packages, and had just tried to install linter-flake8.  I had to add `C:\Python27\Scripts` to my environment variables to use `pip`.  I have uninstalled and reinstalled atom.  My environment variables is currently: 

`C:\Windows\system32\cmd.exe;C:\Ruby21\bin;%ProgramFiles(x86)%\Git\cmd;C:\Python27;C:\HashiCorp\Packer;C:\Python27\Scripts;C:\Users\willem\AppData\Local\atom\bin;C:\Users\willem\AppData\Local\atom\app-0.204.0`

#2

There’s an open issue on this, I believe:


#3

I’ve posted to that issue on github, but I’ve still not been able to solve this error. Any other suggestions?


#4

Did you guys install it via the normal installer?
Did you have previous versions installed via Chocolatey?
Are you behind any restricted network by any chance?


#5

I installed via the .exe fro atom.io
I think I did try and install it via chocolatey at some point but tbh I don’t remember if this was before or after I had this problem.
I am, but I’ve also had the same problem while at home.

I’m waiting to download the new version, see if that helps.

Reading various SO/Github posts about spawn/ENOENT errors connected with Atom & AtonLinter today I get the impression it may have something to do with not finding the path variables but trying all the suggested workarounds has not fixed this problem for me…