Fetching featured packages failed. Windows 10


#1

When I go to install packages, I get the “Fetching featured packages failed” message.
Below it says:
spawn C:\WINDOWS\system32\cmd.exe; ENOENT

I’ve check my COMSPEC variable, and it’s C:\WINDOWS\system32\cmd.exe. I checked to make sure cmd was there, and it was.
I’m not sure what to do at this point. Any help provided would be great, thanks.


#2

When did this start? Do you have any terminal packages installed? Do they work?


#3

This is a fresh install of atom, just happened today. I haven’t installed any packages for atom besides the preinstalled ones.


#4

Have you tried rebooting?


#5

Yeah. I’ve also tried reinstalling, and neither worked.


#6

It looks like I can install packages through the command line with apm install, but I’m still not sure why it won’t work through atom’s setting view.


#7

I haven’t a clue, myself. Try this, though: download one of the Atom-x64-Windows.zip releases and configure that in portable mode somewhere, and see if that Atom can access cmd.