Fetching featured packages failed in Atom 1.0 on Windows 7


#1

Installed Atom 1.0 on a Windows 7 machine.

When I go to Install Packages under settings, i see an error:

Fetching featured packages failed.

Show output:
spawn C:\Windows\system32\cmd.exe;C:\Program Files\Java\jdk1.8.0_25\bin ENOENT

Same error when I look at updates.

Suggestions on what to look at?


#2

Are you behind a proxy?


#3

Not behind a proxy.


#4

This is the error message you get? What is your COMSPEC environment variable set to?


#5
%SystemRoot%\system32\cmd.exe;C:\Program Files\Java\jdk1.8.0_25\bin

Couldn’t say why though, I can’t recall ever touching that.


#6

Yea something messed with that, probably by trying to add what is normally JAVA_HOME to the PATH, but instead of PATH it was added to COMSPEC.

COMSPEC should normally only point to the cmd.exe executable.


#7

Gotcha. I kind of figured that was the case once I looked at it. Removing the java line looks to have worked.

Thanks guys!


#8

I’m actually surprised that I remembered the COMSPEC thing :laughing:


#9

Yea nice catch.