Feedback & questions about atom-minify

Hello everyone!

If you have any feedback or questions about my atom-minify package, here is the right place for ti!

If you have issues, please post it on GitHub!

I see there is a way to customize minified filenames, but is there a way to configure file paths where minified files are saved as well?

1 Like

At the moment, there is no way for that, sorry!

In future I want to implement a first-line-parameter solution like in my sass-autocompile package. So you can overwrite the global settings by placing the parameters into the first line as parameter.

Here an example how it will work. Global setting for filename pattern is: $1.min.$2. So file will be created in directory of the unminified file. But when you define this first line in your unminified file, the minified file will be placed in the subdirectory:

/* filenamePattern: ../path/to/minified/files/$1.min$2 */

I think this feature will be published with next version 0.3, this or next week.

1 Like

I published version 0.3 right now. With this version I introduced inline parameters. Have a look at the documentation for that. I also introduced some useful new features and options.

Direct link to

Hi Armin —

Great work on atom-minify. I have mine set to minify on save, but I’d really prefer to set this as a parameter in the file I’m working on instead of having it set globally. For example, I already use the parameter / compress: true */* so perhaps something like / save: true */* . If set to true the file will be saved using the filename pattern, if set to false then no minified file will be save, and if not present then use the global default value. What do you think? Would also be cool to override the default filename pattern using / save: filename */*. Just a thought.

Anyway thanks again for atom-minify, been using it for a week since you fixed the CSP restrictions and it is an excellent tool. Regards!

That’s really an interessting feature! I think I will include it in next release. I will post here when I published a new version with this parameter. Thanks!

Thank you :slight_smile: Looking forward to it!

Hey! I added the feature you requested. Have a look at this inline parameter.

I’m using Minify since 2 weeks now but since yesterday I can’t Minify anymore.
It asks me to install Java, what I have done but it’s still not working :confused:
Is the someone that had the same issue and can help please?

Hey! That’s interessting. Which OS do you use? MacOS, Linux or Windows? I think there is a “problem” with your Java installation, so my package cannot access Java executable – perhaps the PATH entry is missing.

First of all, open cmd (Windows) or your terminal (Linux/MacOS) and enter java -version. What is the output when you press enter?

If command yould not be found, you can check this manual. It helps you setting the PATH variable right, so that Java executable could be found, even by my package.

Hello and thanks.
i’m on MacOS . I tried java -version and it says :
"No Java runtime present, requesting install."
But I installed Java this morning. I’ll try The manual you Linked . Thanks

1 Like

Hi guys!

I was wondering if anyone else here had any issues with this package when using arrow functions and back ticks?

I wanted to minify my project’s JS files and ran into some java compiling errors. The arrow functions were read as a syntax errors. By re-writing the arrow functions as vanilla functions it solved the problem but I also noticed issues with back ticks, specifically trying to do something like:
name: ${}

The errors I got for these were illegal character errors. Are these issues common or they anomalous? Perhaps I should update java?

Hi @hickone,

Were you able to figure this issue out? If it’s still giving you trouble try to make sure you can see the Java icon in your mac’s system preferences first. If you’ve downloaded it and it’s not there, you may need to go to here. I originally tried downloading it through Atom’s link but was unable to effectively download it. It was on my system but for some reason wasn’t being recognized by my editor or my terminal when I tried to run java commands. Here are some helpful instructions about installation on Mac.

Let me know if this was helpful or if you’d like to know more! Good luck :slight_smile:

How can I set up my own file extensions? e.g. filename.new_js

Hello @hickone,

For this issue first you need to check Java is installed or not.
If you have already installed java in your mac PC then you can see the below screen-shot:

If you have not found this icon then you need to install Java.
Go to official website for java and install java.

After installed Java you have seen java icon in settings.

For resolved this error please follow below steps after installed Java.
Go to settings -> java -> Click on java tab -> View -> User -> Path

Copy path from there and past it in Atom -> minify -> settings -> Advance->java path
Here I have shred the scrren-shot for your reference:

Note: in screen-shot this is my mac pc path so, please ignore and found out your mac pc java path with above steps.

Let me know if this was helpful or if you’d like to know more! Good luck :slightly_smiling_face: