Fedora Dependency Problem for 1.7 Upgrade, nothing provides libffmpeg.so()(64bit) needed by atom-1.7.0-1.*.x86_64


#1

Hopefully this is the correct forum. Feel free to redirect me.

[root@dev02 ~]# dnf install atom-1.7.0-1.fc22.x86_64
Last metadata expiration check performed 0:52:20 ago on Sun Apr 17 07:09:52 2016.
Error: nothing provides libffmpeg.so()(64bit) needed by atom-1.7.0-1.fc22.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages)

[root@dev02 ~]# dnf --allowerasing install atom-1.7.0-1.fc22.x86_64
Last metadata expiration check performed 0:52:36 ago on Sun Apr 17 07:09:52 2016.
Error: nothing provides libffmpeg.so()(64bit) needed by atom-1.7.0-1.fc22.x86_64

[root@dev02 ~]# dnf list ffmpeg
Last metadata expiration check performed 0:52:45 ago on Sun Apr 17 07:09:52 2016.
Available Packages
ffmpeg.x86_64                                               2.6.8-1.fc22                                               rpmfusion-free-updates

There is a similar problem with a different product here (an automatic dependency problem and possible solutions):


#2

sudo dnf update --best --allowerasing
Error: nothing provides libffmpeg.so()(64bit) needed by atom-1.7.0-1.fc23.x86_64

Same here, was just googling this. Upgrading from 1.6->1.7 on Fedora 23 with helber/atom copr repo.


#3

Please open an Issue on https://github.com/atom/atom/ for this and @mention me (@lee-dohm on GitHub) on it so I can direct the developers to it.


#4

Done, thanks:


#5

You can try to use Fedora Copr repository. It is very easy to use, no need to manually download the rpm package.

Please visit https://copr.fedorainfracloud.org/coprs/mosquito/atom :blush:

$ sudo dnf copr enable mosquito/atom
$ sudo dnf install atom

#6

This worked. I was using the helber-atom repo. Of note, the helber repo installed about 3 packages. This repo install installed 93 (mostly nodejs-* packages). Also, mosquito installed 1.71 (atom-1.7.1-1.git5dda304.fc22.x86_64.rpm), a later version.

Thanks.