Failed to push v0.1.0 tag while publishing package, again


#1

I’m trying to publish my package. I’ve sync’d it with github and it is all setup - the github repo is here. This is basically the same as this topic however, I did not see a resolution. I don’t think that I have tags that could be causing the problem - but, honestly, I don’t have a clue because I don’t have any idea where to look or what to check.

When I try to publish I get this message:

Saving token to Keychain done
Registering colorguide done
Preparing and tagging a new version done
Pushing v0.1.0 tag failed

Sadly, I tried a couple of things I read about this and have run the apm publish several times - version is not 0.4.0 - not sure what to do about this either. I’d very much appreciate some help

Worked on this for the last two days and I finally resolved. I did find a log file that said that the repository was dirty.

First, I installed 1.10.0-beta0 (this was a real problem too). Then I deleted all of the branches and did a git clean -n -d -x -f to determine what may be causing the problems (which turned up nothing). I then sync’d again because the package.json files were not matching. The next time I tried to publish it worked.

As a side note, I suggest that when apm asks for a password, it should at least display asterisks so you know when something has been entered.