Failed to install packages


#1

Whenever I try to install any package, it keeps failing and shows this message:

gyp info it worked if it ends with ok
gyp info using node-gyp@3.4.0
gyp info using node@6.9.5 | darwin | x64
gyp http GET https://atom.io/download/electron/v2.0.4/iojs-v2.0.4.tar.gz
gyp WARN install got an error, rolling back install
gyp ERR! install error
gyp ERR! stack Error: self signed certificate in certificate chain
gyp ERR! stack at Error (native)
gyp ERR! stack at TLSSocket. (_tls_wrap.js:1079:38)
gyp ERR! stack at emitNone (events.js:86:13)
gyp ERR! stack at TLSSocket.emit (events.js:185:7)
gyp ERR! stack at TLSSocket._finishInit (_tls_wrap.js:603:8)
gyp ERR! stack at TLSWrap.ssl.onhandshakedone (_tls_wrap.js:433:38)
gyp ERR! System Darwin 16.0.0
gyp ERR! command “/private/var/folders/8r/8n4j2jfn56x40y5yq_6msqdm0000gn/T/AppTranslocation/2F28CFCC-BD1F-4FF3-95A6-3324FCB6317D/d/Atom.app/Contents/Resources/app/apm/bin/node” “/private/var/folders/8r/8n4j2jfn56x40y5yq_6msqdm0000gn/T/AppTranslocation/2F28CFCC-BD1F-4FF3-95A6-3324FCB6317D/d/Atom.app/Contents/Resources/app/apm/node_modules/node-gyp/bin/node-gyp.js” “install” “–runtime=electron” “–target=2.0.4” “–dist-url=https://atom.io/download/electron” “–arch=x64” “–ensure”
gyp ERR! cwd /Users/Michelle/.atom
gyp ERR! node -v v6.9.5
gyp ERR! node-gyp -v v3.4.0
gyp ERR! not ok

I’ve tried installing both from the atom software and terminal.

Atom version 1.28.1, on macOS Sierra v 10.12


#2

gyp ERR! stack Error: self signed certificate in certificate chain

Based on this error, see if this FAQ item helps:


#3

Is there any way I can fix this issue without having unsecured connections? I’m using my own private computer, and I don’t have any proxies or firewall. What’s the worst thing that can happen if i use that command, like how possible is it that I may be attacked with viruses?


#4

I just tried using that command but it hasn’t worked. Again, I do not have any proxies or firewall.

This is what comes up now when I try to install a package:

npm WARN deprecated coffee-script@1.12.7: CoffeeScript on NPM has moved to “coffeescript” (no hyphen)
npm WARN deprecated react-tools@0.12.2: react-tools is deprecated. For more information, visit https://fb.me/react-tools-deprecated
npm WARN deprecated jade@1.11.0: Jade has been renamed to pug, please install the latest version of pug instead of jade
npm ERR! Darwin 16.0.0
npm ERR! argv “/private/var/folders/8r/8n4j2jfn56x40y5yq_6msqdm0000gn/T/AppTranslocation/9160D12E-82FB-4322-9226-8D3561067F9A/d/Atom.app/Contents/Resources/app/apm/bin/node” “/private/var/folders/8r/8n4j2jfn56x40y5yq_6msqdm0000gn/T/AppTranslocation/9160D12E-82FB-4322-9226-8D3561067F9A/d/Atom.app/Contents/Resources/app/apm/node_modules/npm/bin/npm-cli.js” “–globalconfig” “/Users/Michelle/.atom/.apm/.apmrc” “–userconfig” “/Users/Michelle/.atom/.apmrc” “install” “/private/var/folders/8r/8n4j2jfn56x40y5yq_6msqdm0000gn/T/d-118619-9561-r8aaub.mavhl1sjor/package.tgz” “–runtime=electron” “–target=2.0.4” “–arch=x64” “–global-style”
npm ERR! node v6.9.5
npm ERR! npm v3.10.10
npm ERR! code EREADFILE

npm ERR! Error extracting /Users/Michelle/.atom/.apm/typescript-compiler/1.3.0/package.tgz archive: ENOENT: no such file or directory, open ‘/Users/Michelle/.atom/.apm/typescript-compiler/1.3.0/package.tgz’
npm ERR!
npm ERR! If you need help, you may report this error at:
npm ERR! https://github.com/npm/npm/issues

npm ERR! Please include the following file with any support request:
npm ERR! /private/var/folders/8r/8n4j2jfn56x40y5yq_6msqdm0000gn/T/apm-install-dir-118619-9561-jxlhh9.iyvuzq6w29/npm-debug.log


#5

Are you getting the same type of error if you try to install any package or just a particular package?

Also, did package installation work for you previously but stopped working with 1.28.1?


#7

Alright, I tried installing other packages and they’re fine now. I guess that particualr package was just deprecated. Thanks a lot.