Failed in Installing Atom Editor

There is a problem during installation of “Atom Editor”, a window appears showing “update has stopped working” after it other window appears showing “installation has failed”.
Images related to the topic has been attached.
“Operating System- windows 7 ultimate 32 bit”

setup log "2836> 2019-09-11 11:22:34> Program: Starting Squirrel Updater: --install .
2836> 2019-09-11 11:22:34> Program: Starting install, writing to C:\Users\R_S\AppData\Local\SquirrelTemp
2836> 2019-09-11 11:22:34> Program: About to install to: C:\Users\R_S\AppData\Local\Discord
2836> 2019-09-11 11:22:34> SingleGlobalInstance: Grabbing lockfile with timeout of 00:00:10
2836> 2019-09-11 11:22:34> CheckForUpdateImpl: Reading RELEASES file from C:\Users\R_S\AppData\Local\SquirrelTemp
2836> 2019-09-11 11:22:34> CheckForUpdateImpl: Remote version 0.0.305 differs from local
2836> 2019-09-11 11:22:34> CheckForUpdateImpl: First run or local directory is corrupt, starting from scratch
2836> 2019-09-11 11:22:35> ApplyReleasesImpl: Writing files to app directory: C:\Users\R_S\AppData\Local\Discord\app-0.0.305
2836> 2019-09-11 11:22:41> ApplyReleasesImpl: Moving file C:\Users\R_S\AppData\Local\Discord\app-0.0.305\lib\net45\app.ico to C:\Users\R_S\AppData\Local\Discord\app-0.0.305\app.ico
2836> 2019-09-11 11:22:41> ApplyReleasesImpl: Moving file C:\Users\R_S\AppData\Local\Discord\app-0.0.305\lib\net45\chrome_200_percent.pak to C:\Users\R_S\AppData\Local\Discord\app-0.0.305\chrome_200_percent.pak
2836> 2019-09-11 11:22:41> ApplyReleasesImpl: Moving file C:\Users\R_S\AppData\Local\Discord\app-0.0.305\lib\net45\d3dcompiler_47.dll to C:\Users\R_S\AppData\Local\Discord\app-0.0.305\d3dcompiler_47.dll
2836> 2019-09-11 11:22:41> ApplyReleasesImpl: Moving file C:\Users\R_S\AppData\Local\Discord\app-0.0.305\lib\net45\Discord.exe to C:\Users\R_S\AppData\Local\Discord\app-0.0.305\Discord.exe
2836> 2019-09-11 11:22:41> ApplyReleasesImpl: Moving file C:\Users\R_S\AppData\Local\Discord\app-0.0.305\lib\net45\chrome_100_percent.pak to C:\Users\R_S\AppData\Local\Discord\app-0.0.305\chrome_100_percent.pak
2836> 2019-09-11 11:22:41> ApplyReleasesImpl: Moving file C:\Users\R_S\AppData\Local\Discord\app-0.0.305\lib\net45\icudtl.dat to C:\Users\R_S\AppData\Local\Discord\app-0.0.305\icudtl.dat
2836> 2019-09-11 11:22:41> ApplyReleasesImpl: Moving file C:\Users\R_S\AppData\Local\Discord\app-0.0.305\lib\net45\libEGL.dll to C:\Users\R_S\AppData\Local\Discord\app-0.0.305\libEGL.dll
2836> 2019-09-11 11:22:41> ApplyReleasesImpl: Moving file C:\Users\R_S\AppData\Local\Discord\app-0.0.305\lib\net45\libGLESv2.dll to C:\Users\R_S\AppData\Local\Discord\app-0.0.305\libGLESv2.dll
2836> 2019-09-11 11:22:41> ApplyReleasesImpl: Moving file C:\Users\R_S\AppData\Local\Discord\app-0.0.305\lib\net45\natives_blob.bin to C:\Users\R_S\AppData\Local\Discord\app-0.0.305\natives_blob.bin
2836> 2019-09-11 11:22:41> ApplyReleasesImpl: Moving file C:\Users\R_S\AppData\Local\Discord\app-0.0.305\lib\net45\osmesa.dll to C:\Users\R_S\AppData\Local\Discord\app-0.0.305\osmesa.dll
2836> 2019-09-11 11:22:41> ApplyReleasesImpl: Moving file C:\Users\R_S\AppData\Local\Discord\app-0.0.305\lib\net45\resources.pak to C:\Users\R_S\AppData\Local\Discord\app-0.0.305\resources.pak
2836> 2019-09-11 11:22:41> ApplyReleasesImpl: Moving file C:\Users\R_S\AppData\Local\Discord\app-0.0.305\lib\net45\snapshot_blob.bin to C:\Users\R_S\AppData\Local\Discord\app-0.0.305\snapshot_blob.bin
2836> 2019-09-11 11:22:41> ApplyReleasesImpl: Moving file C:\Users\R_S\AppData\Local\Discord\app-0.0.305\lib\net45\Squirrel.exe to C:\Users\R_S\AppData\Local\Discord\app-0.0.305\Squirrel.exe
2836> 2019-09-11 11:22:41> ApplyReleasesImpl: Moving file C:\Users\R_S\AppData\Local\Discord\app-0.0.305\lib\net45\v8_context_snapshot.bin to C:\Users\R_S\AppData\Local\Discord\app-0.0.305\v8_context_snapshot.bin
2836> 2019-09-11 11:22:41> ApplyReleasesImpl: Moving file C:\Users\R_S\AppData\Local\Discord\app-0.0.305\lib\net45\VkICD_mock_icd.dll to C:\Users\R_S\AppData\Local\Discord\app-0.0.305\VkICD_mock_icd.dll
2836> 2019-09-11 11:22:41> ApplyReleasesImpl: Moving file C:\Users\R_S\AppData\Local\Discord\app-0.0.305\lib\net45\VkLayer_core_validation.dll to C:\Users\R_S\AppData\Local\Discord\app-0.0.305\VkLayer_core_validation.dll
2836> 2019-09-11 11:22:41> ApplyReleasesImpl: Moving file C:\Users\R_S\AppData\Local\Discord\app-0.0.305\lib\net45\VkLayer_object_tracker.dll to C:\Users\R_S\AppData\Local\Discord\app-0.0.305\VkLayer_object_tracker.dll
2836> 2019-09-11 11:22:41> ApplyReleasesImpl: Moving file C:\Users\R_S\AppData\Local\Discord\app-0.0.305\lib\net45\VkLayer_parameter_validation.dll to C:\Users\R_S\AppData\Local\Discord\app-0.0.305\VkLayer_parameter_validation.dll
2836> 2019-09-11 11:22:41> ApplyReleasesImpl: Moving file C:\Users\R_S\AppData\Local\Discord\app-0.0.305\lib\net45\ffmpeg.dll to C:\Users\R_S\AppData\Local\Discord\app-0.0.305\ffmpeg.dll
2836> 2019-09-11 11:22:41> ApplyReleasesImpl: Moving file C:\Users\R_S\AppData\Local\Discord\app-0.0.305\lib\net45\VkLayer_threading.dll to C:\Users\R_S\AppData\Local\Discord\app-0.0.305\VkLayer_threading.dll
2836> 2019-09-11 11:22:41> ApplyReleasesImpl: Moving file C:\Users\R_S\AppData\Local\Discord\app-0.0.305\lib\net45\VkLayer_unique_objects.dll to C:\Users\R_S\AppData\Local\Discord\app-0.0.305\VkLayer_unique_objects.dll
2836> 2019-09-11 11:22:43> ApplyReleasesImpl: Started updateSelf pid 2580
2836> 2019-09-11 11:22:45> ApplyReleasesImpl: Squirrel Enabled Apps: [C:\Users\R_S\AppData\Local\Discord\app-0.0.305\Discord.exe]
2836> 2019-09-11 11:22:45> Utility: Process Started: C:\Users\R_S\AppData\Local\Discord\app-0.0.305\Discord.exe --squirrel-install 0.0.305, pid 3976
2836> 2019-09-11 11:22:49> Utility: Received exitcode 0 from process C:\Users\R_S\AppData\Local\Discord\app-0.0.305\Discord.exe
2836> 2019-09-11 11:22:49> ApplyReleasesImpl: ran C:\Users\R_S\AppData\Local\Discord\app-0.0.305\Discord.exe, pid 3296
2836> 2019-09-11 11:22:49> ApplyReleasesImpl: Starting fixPinnedExecutables
2836> 2019-09-11 11:22:49> ApplyReleasesImpl: fixPinnedExecutables: newCurrentFolder: app-0.0.305
2836> 2019-09-11 11:22:49> ApplyReleasesImpl: Updating shortcut C:\Users\R_S\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Discord Inc\Discord.lnk
2836> 2019-09-11 11:22:49> ApplyReleasesImpl: Updating shortcut C:\Users\R_S\Desktop\Discord.lnk
2836> 2019-09-11 11:22:49> ApplyReleasesImpl: Fixing up tray icons
2836> 2019-09-11 11:22:49> ApplyReleasesImpl: cleanDeadVersions: for version 0.0.305
2836> 2019-09-11 11:22:49> ApplyReleasesImpl: cleanDeadVersions: exclude current version folder app-0.0.305

Hello. I have the same problem, in windows 8.1. i got this error message when i was running just plane windows 8, but after the update i just got the same message. (Update has stopped working). Then i tried to delete any kind of anti-virus programs i have, or so even just deactivate them for the time being. But still, got the same error message. then i tried to delete all the “temp” folders in appdata, but nothing worked. Is there any solution for this problem, because i need this program for school. Thanks for replies!

I also want solution of the problem.Thanks for replies!

Greetings I need the solution for this problem too. Thanks for the replies

If you’re having trouble with the installer give this a try:

  1. Exit all Atom instances
  2. Uninstall any Atom from Control Panel > Add remove programs
  3. Manually delete the %LocalAppData%\atom directory
  4. Download the latest installer from and then reinstall Atom

If that doesn’t work, another option is to use the or file from the releases page. Extract it to say C:\atom and run it from there though this version of Atom doesn’t auto-update so you would have to download the latest .zip if there’s another release.

1 Like

[attempting to suggest a possible cause]

@rsese: Hello Robert.

It may be worth enquiring from users what the size is of the download file was. A checksum (SHA256 / MD5 / …) of the install file may be of value.

My internet connection to Github’s servers is not reliable (slow). Several times it has happened to me that the download of Atom was aborted.

The install file was built up to more than 90% of the size, for most cases. Neither Firefox nor Windows detected that the download is not complete. The install process could be started.

The symptoms mentioned in this topic I have not seen on my Windows 10 Pro (1903) machine. My situation might not been a perfect storm.

Should we be concerned when…

  • There was no blog entry for Atom V1.40
  • Publish cycles (nightly / beta / stable) are getting longer
  • The star helper of this community is MIA
  • ‘issues’ for Atom on Github project page does not have the usual feel of pushing for progress.

Kind regards to the Atom team.

is there no actual fix to this with the installer? is this just with latest version

That’s reasonable to check :+1: I’m used to Chrome on macOS where I’m pretty sure it tells you if something didn’t download successfully, I think I assumed it was similar with Chrome on Windows.

About your other comments, this has been touched on in other channels like the Atom Slack but the Atom project goes through ebbs and flows as the makeup of the team changes over time; the current pace of development is temporary.

About the blog entry, related to the current pace of development, we didn’t think there were enough changes for a blog post last time around.

And similarly, the makeup of the community on the message board also changes over time for a number of reasons and as things in their lives change.

What version of Windows are you running? And are you only having trouble with 1.40? Does 1.39 install fine for you?

Windows 8! yeah just seems to be this current version. 1.39 installs from a zip and works.

Is that 32-bit or 64-bit @jimjams?

oh! 64-bit

@jimjams sorry one more question - can you share your SquirrelSetup.log file so we can see any installation errors? The file should be located in %AppData%/Local/atom - if you have any trouble pasting it you can share it as a gist:

hi sorry just having trouble finding that. So I went into appData > Local > atom but i dont see squirrelSetup.log.

I have had exactly the same problem with the latest version. Windows 8 64 bit.

I had the same issue with atom on a windows 7 64-bit as well. I followed the directions to uninstall atom from the control panel, (there wasn’t anything to uninstall,) deleted the atom folder in the local directory, downloaded the zip file, extracted the zip file to c:\atom and now atom works. And my packages are working correctly for the first time. However, atom is not listed in my list of available programs. I have to search for it to launch the program. But I am happy that it at least works now. :smile: Thanks for this thread.

This is my solution. I experienced this problem when installing Atom on versions of Windows lower than Windows 10. To fix this problem, This is the only legit workaround I have discovered so far:

Right click the installer. Extract the installer using: 7-zip. Do the same thing to atom-1.45.0-full.nupkg. Right click and extract with 7-zip. Navigate to net45 or copy that directory to C:/net45 and rename it to C:/atom. Click atom.exe.

You have just managed to make your portable version of Atom! From there, you can install packages as normal like remote-ftp and choose to save this entire atom folder to a flash drive, to work on the go!

No need to install or reinstall Atom. If you’re happy with 32 bit, it will work on all 32 and 64 bit windows systems. I prefer the 64 bit as most people these days have 64 bit PC.

After all, open-source software (FOSS) deserves the right to be portable. The only good thing about this installer, is that the installer and the portable file are packaged as one file.

This is how you can make the most out of this Windows bug! I’m attaching a screenshot to show my use case.

Hope this helps someone out there having this issue.

Thank you,


1 Like

2nd option worked for me.
Thank you so much.

much easier solution found
copy AtomSetup-x64.exe to c root unzip (using 7zip software) AtomSetup-x64.exe go to C:\AtomSetup-x64\atom-1.55.0-full\lib\net45 clk on atom.exe sucess