Fail Atom Update from 1.18.0 x64 to 1.19.0 on macOS Sierra


#1

Click Restart and install. The app closed completely. Waited for some times (tried both short and long wait times). And then, relaunch the app. The screen below popped up.

Clicked OK.

Back to download page where the app is downloading again. And, after the download, back to the first screen.

How to solve this issue, please?


#2

I’m experiencing the same issue with Atom 1.19.0 on macOS Sierra. I’m looking into it, trying to find why this happens.


#3

I was going to give this a couple of tries, but first I decided to uninstall two packages that were installed and I no longer require for now (platformio-ide-terminal and Hydrogen), and after the first restart it correctly updated the version.
Have you tried starting Atom in safe mode anyway?


#4

@b3by, I tried safe mode, reset the app to factory setting and sudo command. All gave the same results as above. So, I just screenshot my preferences and clean reinstalled the latest version. Thanks for your reply.