F3 does not work with autocomplete-clang


#1

i just installed atom for C++ programming. I installed autocomplete-clang and added a clang-complete to my project root directory with one line:

-I./include

But, I can’t go to declaration by pressing F3 or vice-versa. And, I am also not getting basic suggestions like iostream with:

#include<iost…>

I am on Ubuntu 16.04 and clang is installed. Am I missing some setting? Is there a way to debug if the package is working or not?


#2

The people here aren’t necessarily going to be experienced with autocomplete-clang. You might have better luck if you ask at the package repo.