Extremely Slow Launch on Mac


#1

Atom takes between three and five minutes to start on my Mac, during which the entire computer freezes/hangs and is not usable. I have not experienced this issue with any other applications on my Mac.

Notable details:

  • Atom version: 1.0.2
  • OS X version: 10.10.4
  • Happens every time I start Atom, even with the --safe flag
  • Everything behaves normally after Atom has finished starting

The computer hangs because starting Atom causes /System/Library/CoreServices/launchservicesd to go to > 100% CPU until Atom has finished starting.

After seeing the launchservicesd behavior, I tried resetting the Launch Services database using the following command, which seemed to have no effect: /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -domain local -domain system -domain user

This is frustrating to say the least.

Is there anything I can try?


#2

Try renaming or deleting ~/.atom directory while no windows are open.


#3

How are you launching Atom? From the icon? From the command line? If from the command line, what is your current working directory when you do?


#4

I tried renaming the ~/.atom directory; it did not help.


#5

The same behavior happens regardless of whether I open Atom by double-clicking the icon, running it from the command line, or opening it using Spotlight.

There is a similar hang while Atom is closing, as well, but it usually doesn’t last as long as the opening hang.


#6

I’ve been running Atom on OS X 10.10.4 for quite a while now and I’ve never seen something like this. When you start Atom from the command line, what is your current working directory? Can you try this:

  1. Open a Terminal
  2. Enter the command: mkdir dump
  3. Enter the command: 'cd dump`
  4. Enter the command: atom .

See if that helps.


#7

Create a test user and attempt to open Atom. If it still opens slowly, then you’re looking in the root library (/System/Library/) for the issue to be repaired.

Easiest way to nuke the system and fix it while retaining data is an archive and install from recovery. Just tell it to re-install OS X without erasing the drive and it will return your system library to factory while retaining your user folder. Obviously make a backup before attempting.

If it functions normally in the test user (i.e. you don’t see the same slow load behavior subjectively or in Activity Monitor) then you’re looking at a user-specific issue. Most likely related to packages or configuration of Atom and/or your user, possibly just a fluke issue that can be resolved by uninstalling Atom and all it’s files in the user Library folder as well as the .atom folder.

If none of that works let me know, I’d love to help you figure this one out just for my own benefit.


#8

This is embarrassing, but out of all of the stuff I had tried, I didn’t think to try restarting the computer, which did indeed fix the issue.

It had 10 days of uptime, and I’m not sure what happened that got it into that state, but at least it’s better now.

I’ll report back here if the issue resurfaces.

In any case, thanks very much for your suggestions!