Exit full screen mode


#1

Hi,

I am using Linux Ubuntu and cannot exit full screen mode anymore which is an absolute nightmare. I have tried all of the suggestions found in the forums here, F11, installing-re-installing. Can you please help?

Thanks


#2

Hello.

It is strange that the F11 button does not work. To me it sounds as if that button is assigned elsewhere or a package (like ‘zen’) is giving this functionality.

OPTIONS

  1. Ctrl-Shift-P to bring up the command pallet. Start typing full screen in the popup to find the toggle for full screen mode.

  2. Start a session from the terminal as atom --clear-window-state

  3. Start a session from the terminal as atom --safe

It is an add-on package if only the 3rd option works. Then you have to identify the package that gives this issue.


To bring back the menu bar - if that is hidden:

  • Ctrl-Shift-P to bring up the command pallet. Start typing menu.

Does this help you?


#3

That worked! Thank you so much. X


#4

…please - - what did you use?


#5

I used - control shift P- and then searched for the full screen option and that did the job. I reckon F11 wasn’t working because I am using a virtual machine with Ubuntu on my french keyboard mac - not a good combo!- so all the keys are completely out of sync.

Thanks again for your help.


#6

…that can get complicated very fast.

Thank you for returning my call. As “thanks” let me give you a tip.

  1. Ctrl-Shift-P

  2. image

  3. image

The Key Binding Resolver opens at the bottom of your Atom session. It tells you 2 things:

  • which key commands does Atom think you used

  • with which command is it linked to

So in your case you can press F11 and see what does Atom think it is. From there you can decide to place a custom key combination in your Keymap file.

Did you already know of this?
Regards.


#7

amazing, thanks! i didn’t know of it. Will go to bed wiser today :slight_smile: