Every time I open Atom, it is slightly too big for my screen


#1

Is there any way to add to my init file or change a setting that will make Atom maximize the window, or even set the window size every time a new window is created?

I searched the API and it seems there is a function Window::Maximize() but I am not sure how to call this from my init file.


Let atom open maximized windows
#2

I suspect you’re looking at the Atom Shell API, not the Atom API:

https://atom.io/docs/api/v0.115.0/api/

I don’t know of a Window::Maximize() method in the Atom API.

Nonetheless, @AbeEstrada created a package Remember Window that remembers the size and position of your window on the screen when you close it. Then when you open it the next time, it opens where you had it.


#3

on osx atom does remember its window size and position without any package needed to be installed. it does not remember how many windows was left open on closing atom. but the most recent active window position and size is saved and restored. i guess its an osx behavior because at work on my hated windows machine it starts always on 2nd screen.


#4

It’s not maximized on start on Windows as well. And the window height is slightly larger than screen:

Not a big deal by any means, just a little bit sloppy.


#5

Moved this to the more current topic rather than resurrecting an old topic. Your post matches the new topic better anyway :grinning:


#6

You are correct, I wasn’t looking at the API.


#7

the package does what it promises, but the problem is within Atom itself. I suspect it has trouble calculating window height. When I go into Remember Window package settings I see 1096 in height field, although my display height is 1080 (and the window is maximized). So, if I restart it, window will be larger than screen (see the screenshot).


#8

It looks like there is an Issue open on this: