Every day the Welcome screen appears


#1

Zdravsvujte, at me a problem. When Atom 1.27.1 is started, every day, the “Welcome” window appears:


I tried to reinstall Atom, it did not help. Anyway, every day the window “Welcome” appears.
In the options, I also tried to disconnect it.
On other computers, this problem does not arise.
Tell me with what it may be connected?


#2

In the options, I also tried to disconnect it.

I see the “Show Welcome Guide when opening Atom” checkbox is still checked in your screenshot - did you uncheck it but when you restart Atom it’s still checked?


#3

Yes, I tried to clean it.
But the next day, the “Welcome” window reappears.
Not after restarting the computer, but only the next day …


#4

One of two options:

  1. (see image)

  2. Merge the following code into the configuration file:
    ( .../.atom/config.cson)

"*":
  core:
    disabledPackages: [
      "welcome"
    ]

#5

The first method did not help. In occasion of the second, and where this file config.sson lays, I can not find it.


#6

It’s in the .atom/ folder in your user folder. You may have to tell your file browser to show you hidden files. You can also go to the menu bar and pull down File, then click on Config..., which will open config.cson in Atom for you to edit.


#7

now my config file looks like this:
“*”:
“atom-package-deps”:
ignored: [
“linter-pycodestyle”
]
core:
telemetryConsent: “no”
uriHandlerRegistration: “never”
editor:
fontSize: 19
“exception-reporting”:
userId: “c490ddfe-b088-4b82-abf3-2b898a2136fa”
welcome:
showOnStartup: false

But the welcome window still appears …


#8

What happens if you add the disabledPackages key as @danPadric indicated?


#9

Problem solved.
Not sure, but it seems that the reason for the solution is the update of the connected packages.