Error when trying to run Python on Windows 10


#1

For some reason every time I try to run Python on Atom then I keep receiving the error:

“‘python’ is not recognized as an internal or external command,
operable program or batch file.”

I have been doing research on this and most people have this issue solved by adding Python to their “Path”; however, I have already done this and reinstalled Python multiple times.

At this point I don’t know what else to do…please help.

I am new to programming so please try to be patient lol


#2

If Python is added to your PATH, you do not need to reinstall it and it will work. Open the command line and type python --version. If you get the same error, then you have not added Python to your PATH and you should share that with us as well as the location of your Python so that we can tell you what to add.


#5

I am fairly certain that Python is added to my Path because when I downloaded Python I made sure to check the “add to path” option.

The issue may have to do with my script package because I am receiving this error:

[Enter steps to reproduce:]

Atom: 1.27.2 x64
Electron: 1.7.15
OS: Microsoft Windows 10 Pro
Thrown From: script package 3.18.1

Stack Trace

Uncaught TypeError: Cannot read property ‘indexOf’ of undefined

At C:\Users\nicod\.atom\packages\script\lib\runner.js:180

TypeError: Cannot read property 'indexOf' of undefined
    at Runner.getProjectPath (/packages/script/lib/runner.js:180:19)
    at Runner.getCwd (/packages/script/lib/runner.js:79:22)
    at Runner.options (/packages/script/lib/runner.js:130:17)
    at Runner.run (/packages/script/lib/runner.js:27:26)
    at Runtime.execute (/packages/script/lib/runtime.js:78:17)
    at HTMLElement.scriptRun (/packages/script/lib/script.js:98:40)
    at CommandRegistry.handleCommandEvent (~/AppData/Local/atom/app-1.27.2/resources/app/src/command-registry.js:384:49)
    at KeymapManager.module.exports.KeymapManager.dispatchCommandEvent (~/AppData/Local/atom/app-1.27.2/resources/app/node_modules/atom-keymap/lib/keymap-manager.js:621:22)
    at KeymapManager.module.exports.KeymapManager.handleKeyboardEvent (~/AppData/Local/atom/app-1.27.2/resources/app/node_modules/atom-keymap/lib/keymap-manager.js:412:28)
    at WindowEventHandler.handleDocumentKeyEvent (~/AppData/Local/atom/app-1.27.2/resources/app/src/window-event-handler.js:110:40)

Commands

  2x -9:27 core:backspace (input.hidden-input)
     -6:57.4.0 core:save-as (ul.list-inline.tab-bar.inset-panel)
  2x -6:35.6.0 script:run (input.hidden-input)
     -6:33.3.0 fuzzy-finder:toggle-buffer-finder (input.hidden-input)
     -6:28.9.0 script:run (input.hidden-input)
 15x -6:24.8.0 core:backspace (input.hidden-input)
     -5:33.2.0 core:paste (input.hidden-input)
     -5:31.7.0 editor:newline (input.hidden-input)
     -5:28.2.0 script:run (input.hidden-input)
     -5:26.3.0 editor:newline (input.hidden-input)
     -5:22.5.0 core:backspace (input.hidden-input)
     -5:21.5.0 editor:newline (input.hidden-input)
  4x -5:20 core:backspace (input.hidden-input)
  2x -5:13 script:run (input.hidden-input)
  2x -3:28.2.0 core:backspace (input.hidden-input)
     -3:22.2.0 script:run (input.hidden-input)

Non-Core Packages

script 3.18.1 

#6

Have you restarted Atom since then? Environment variables are picked up when programs start, and most programs don’t refresh their environments on their own.

The issue may have to do with my script package because I am receiving this error

How and when is the error appearing? What does it look like?


#7

Here is a screenshot of where Python is stored on my computer and my path settings.

I believe the other error I was receiving is irrelevant to this issue because it was only occurring when I tried to edit a specific file.

I have restarted Atom and my computer a few times but still nothing is working.


#8

There’s the mistake: the correct path would be D:\Coding\Languages\Python, without the Python.exe part


#9

Thank you! Sorry for the frustration