Error when trying to activate the command palette


Recently, I’ve had issues activating the command palette. I launched the console to see what’s going on, and here’s the output that appears to be relevant:

Failed to activate package named 'command-palette' Error: The `::command` method is no longer available on SpacePen views."

Please subscribe to commands via `atom.commands.add`:

Collect the returned subscription objects in a CompositeDisposable:

Call `.dispose()` on your `CompositeDisposable` in this view's `::detached` hook.
  at CommandPaletteView.$.fn.command (c:\Users\mrausch\.atom\packages\linter\node_modules\space-pen\lib\space-pen.js:570:11)
  at CommandPaletteView.module.exports.SelectListView.initialize (d:\Atom\resources\app\node_modules\command-palette\node_modules\atom-space-pen-views\lib\select-list-view.js:80:12)
  at CommandPaletteView.module.exports.CommandPaletteView.initialize (d:\Atom\resources\app\node_modules\command-palette\lib\command-palette-view.js:26:47)
  at CommandPaletteView.View (c:\Users\mrausch\.atom\packages\linter\node_modules\space-pen\lib\space-pen.js:178:25)
  at CommandPaletteView.SelectListView (d:\Atom\resources\app\node_modules\command-palette\node_modules\atom-space-pen-views\lib\select-list-view.js:18:51)
  at new CommandPaletteView (d:\Atom\resources\app\node_modules\command-palette\lib\command-palette-view.js:16:55)
  at Function.module.exports.CommandPaletteView.activate (d:\Atom\resources\app\node_modules\command-palette\lib\command-palette-view.js:20:14)
  at Package.module.exports.Package.activateNow (d:\Atom\resources\app\src\package.js:227:27)
  at d:\Atom\resources\app\src\package.js:656:29
  at Emitter.module.exports.Emitter.emit (d:\Atom\resources\app\node_modules\event-kit\lib\emitter.js:71:11)
  at CommandRegistry.module.exports.CommandRegistry.handleCommandEvent (d:\Atom\resources\app\src\command-registry.js:224:20)
  at d:\Atom\resources\app\src\command-registry.js:3:61
  at KeymapManager.module.exports.KeymapManager.dispatchCommandEvent (d:\Atom\resources\app\node_modules\atom-keymap\lib\keymap-manager.js:544:16)
  at KeymapManager.module.exports.KeymapManager.handleKeyboardEvent (d:\Atom\resources\app\node_modules\atom-keymap\lib\keymap-manager.js:386:22)
  at HTMLDocument.module.exports.WindowEventHandler.onKeydown (d:\Atom\resources\app\src\window-event-handler.js:157:20)

Atom version: 0.148.0
Windows version: 8.1 Pro
Atom was installed from the Windows installer, not from source.

Let me know if there’s any other information I can provide. I’d love my command palette back! :worried:


Try updating to the latest version. The latest release is v0.165.0. Also, there might be something messed up with your installation since there shouldn’t be a version of Atom where this error is possible.


@leedohm Do you know why I’m not being prompted to update Atom? I saw that there have been lots of updates since the version I have, but there’s no update squirrel encouraging me to update. Are all these available for Windows? Should I just download the latest installer from the website and update that way?


Unfortunately, I don’t use Windows … so I’m not the best person to give advice on why this might be happening. In general though, here is what I would do in your situation:

  1. Save a list of the packages I have installed using apm list --installed --bare
  2. Completely uninstall Atom
  3. Install a new copy of Atom from the Releases page
  4. Reinstall my packages using apm install --packages-file wherever-you-stored-the-list.txt

Every version of Atom is available on every platform (OS X, Windows, and all supported flavors of Unix). Things are just much easier to handle that way :grinning:


I’ve learned some things today. When I looked into it, I was not using an installer. I was copying files over from the release. I’ve switched to using the AtomSetup.exe release instead. I don’t know if this was even an option when I started using Atom, but it’s nice to see.

In light of the above, I (technically) had nothing to uninstall, so I just tried the installer without deleting anything out of ~/.atom. The result? Success!

It looks like my copy of Atom just got too out of date for the plugins. Not sure exactly what happened, but it’s fixed now.

Thanks, @leedohm, for your help!


The Windows installer is pretty new. So it may not have been available when you started. Also, that is probably why your installation wasn’t auto-updating too, the zip process you used didn’t auto-update.

I’m glad things are working for you now!