Error when attempting to run Atom on Subgraph OS


#1
nohup "$ATOM_PATH" --executed-from="$(pwd)" --pid=$$ "$@" > "$ATOM_HOME/nohup.out" 2>&1

if the lines are important: /usr/bin/atom: line 117: 3777 Killed

OS running: Subgraph (I know it’s still alpha but can’t resist it’s features)

Already tried connecting to irc channel to ask but freenode blocked tor completly.

any ideas?


#2

I’m not sure what the question is?


#3

Sorry for the poor bug report, just read your blog post (http://www.lee-dohm.com/2015/01/04/writing-good-bug-reports/) and I’ll try to follow it:

When I try to run atom for the first time (I installed atom-amd64.deb from release page, ran dpkg --install atom-amd64.deb just fine) I get the error in the topic title.

I have a 64 bit OS so that’s not the problem.

What do I expect: to start atom for the first time (never ran successful sessions of atom on this OS)

What do I get: /usr/bin/atom: line 117: 1701 Killed nohup “ATOM_PATH" --executed-from="(pwd)” --pid=$$ “$@” > “$ATOM_HOME/nohup.out” 2>&1
(line stays the same, number killed changes every time)

Git is installed and which OS i’m running is stated in original post.

I think it has to do with my display driver/GNOME 3 (classic) because when I try to run redshift colour app for example I get the error display driver :0 or somthing which I have to fix with xhost +. I think that crashes everything up or somthing I could be wrong.

I also tried to build atom from sourrce but the part where it says in the tutorial “script/build” in terminal it goes wrong: it immediately says: killed.


#4

Still have this problem, seems like leedohm knows how to fix this but he hasn’t looked at this thread after original post… I’m trying to PM him but don’t have enough trust yet to PM someone.

Anybody willing to make him aware of my good bug report or should I make a new thread?


#5

Maybe a hint could be in the contents of $ATOM_HOME/nohup.out file, namely ~/.atom/nohup.out: can you post the output of cat ~/.atom/nohup.out (after checking that the problem still exists when running atom with the --safe switch, as many suggest)?


#6

You can @-mention anyone on the board and it notifies them, @AtomBug. Sorry I dropped the ball on your response, sometimes things slip through the cracks.

I’ve never heard of the Subgraph OS before your post and I did some poking around and wasn’t sure I was finding the correct links. A link would be helpful so that I’m sure I’m looking at the right thing.

Can you replicate this on an OS other than Subgraph?


#7

@leedohm

Subgraph

This bug has definitely something to do with this OS because when I tried to run atom on debian it had no issues. (even though Subgraph is Debian-based)

This seems exactly my problem and This should be the fix

he says “Storing it in the temp directory can lead to permissions issues when
Atom is run by multiple users.”

I think this has something to do with my OS because by default every application is run in a sandbox even when I run atom as root I still have this issue.

Also when I check $HOME/.atom/nohup.out as root with gedit it is empty.
Is it supposed to be filled?

Thank you for your help guys.


#8

The fix you linked to is in v1.7.0-beta4. You can install that and try it out right now.


#9

In my case it contains at least the load time (e.g. App load time: 1623ms) but it would normally consist of a combination of stdout and stderr, thus giving some hints about possible errors. In your case the empty file would at least mean that the executable is not even able to report any errors, or that the nohup file is written somewhere else – which may be your case, if you run it as root pre-1.7.0-beta4.