Error: Tunneling socket could not be established statuscode=407


#1

Hi Team,

I have recently installed Atom 1.16.0.

While trying to install package and theme I am seeing below error message.


#2

The most recent version is 1.24.0. Is there a particular reason why you’re using such an old version? If not, you should update as your first debugging step.


#3

Hi, i’m using the last version 1.24.0 and i have the same error.
I’m using Windows 7 Ultimate 64bits.
Thanks you in advance!


#4

Are you connecting to the Internet from behind a firewall or proxy?


#5

Hi, yes i am.


#6

Check out the APM documentation about proxies.


#7

where i must to execute that commands?? I need to install something before???.
Thank you in advance.


#8

No. Even Windows comes with a command-line interface built in.


#9

image
That is the message when i execute the apm command. I am doing something wrong.


#10

You might need to edit your PATH and add C:\Users\dprieto\AppData\Local\atom\bin\ to it.


#11

Thank for your help, but i’dont have that folder.
I have C:\Users\dprieto\AppData\Local\atom\app-1.24.0 and C:\Users\dprieto\AppData\Local\atom\packages
Where can i found that bin folder???


#12

I already found the apm command. I run the commando apm config set https-proxy https://9.0.2.1:0 with our proxy setting, but still not working the plugins install.
Now the message is: “tunneling socket could not be established, cause=write EPROTO 101057795:error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol:openssl\ssl\s23_clnt.c:794:


#13

I don’t have any further insight to offer here, sorry.