Error to load packages installed using apm link in Windows 7


#1

Today I installed the Atom Editor (manually and using choco) - version: 0.136.0.

After that, I install packages using apm link, because I’m behind a company proxy and this is the best solution for me.

But, when I open Atom, I get a lot errors: https://gist.github.com/patrickmaciel/569f7ad38e47f01210fd

For example:

Failed to load package named 'atom-color-highlight' Error: Cannot find module 'emissary'
  at Function.Module._resolveFilename (module.js:344:15)
  at Function.Module._load (module.js:286:25)
  at Module.require (module.js:373:17)

And…

Uncaught Error: Cannot find module 'season' module.js:346
Error activating package config for “ask-stack” Error {code: "MODULE_NOT_FOUND", stack: (...), message: "Cannot find module 'request'"} c:\ProgramData\chocolatey\lib\Atom.0.136.0\tools\Atom\resources\app\node_modules\settings-view\lib\…:416
Error activating package config for “atom-color-highlight” Error {code: "MODULE_NOT_FOUND", stack: (...), message: "Cannot find module 'emissary'"} c:\ProgramData\chocolatey\lib\Atom.0.136.0\tools\Atom\resources\app\node_modules\settings-view\lib\…:416
Error activating package config for “atom-spotify” Error {code: "MODULE_NOT_FOUND", stack: (...), message: "Cannot find module 'spotify-node-applescript'"} c:\ProgramData\chocolatey\lib\Atom.0.136.0\tools\Atom\resources\app\node_modules\settings-view\lib\…:416
Error activating package config for “autocomplete-plus” Error {code: "MODULE_NOT_FOUND", stack: (...), message: "Cannot find module 'underscore-plus'"} c:\ProgramData\chocolatey\lib\Atom.0.136.0\tools\Atom\resources\app\node_modules\settings-view\lib\…:416
Error activating package config for “autocomplete-snippets” Error {code: "MODULE_NOT_FOUND", stack: (...), message: "Cannot find module 'underscore-plus'"} c:\ProgramData\chocolatey\lib\Atom.0.136.0\tools\Atom\resources\app\node_modules\settings-view\lib\…:416
Error activating package config for “autoprefixer” Error {code: "MODULE_NOT_FOUND", stack: (...), message: "Cannot find module 'autoprefixer-core'"} c:\ProgramData\chocolatey\lib\Atom.0.136.0\tools\Atom\resources\app\node_modules\settings-view\lib\…:416
Error activating package config for “change-case” Error {code: "MODULE_NOT_FOUND", stack: (...), message: "Cannot find module 'change-case'"} c:\ProgramData\chocolatey\lib\Atom.0.136.0\tools\Atom\resources\app\node_modules\settings-view\lib\…:416
Error activating package config for “csscomb” Error {code: "MODULE_NOT_FOUND", stack: (...), message: "Cannot find module 'csscomb'"} c:\ProgramData\chocolatey\lib\Atom.0.136.0\tools\Atom\resources\app\node_modules\settings-view\lib\…:416
Error activating package config for “csslint” Error {code: "MODULE_NOT_FOUND", stack: (...), message: "Cannot find module 'atom-keymap-plus'"} c:\ProgramData\chocolatey\lib\Atom.0.136.0\tools\Atom\resources\app\node_modules\settings-view\lib\…:416
Error activating package config for “emmet” Error {code: "MODULE_NOT_FOUND", stack: (...), message: "Cannot find module 'emmet'"} c:\ProgramData\chocolatey\lib\Atom.0.136.0\tools\Atom\resources\app\node_modules\settings-view\lib\…:416
Error activating package config for “fancy-new-file” Error {code: "MODULE_NOT_FOUND", stack: (...), message: "Cannot find module 'mkdirp'"} c:\ProgramData\chocolatey\lib\Atom.0.136.0\tools\Atom\resources\app\node_modules\settings-view\lib\…:416
Error activating package config for “highlight-line” Error {code: "MODULE_NOT_FOUND", stack: (...), message: "Cannot find module 'event-kit'"} c:\ProgramData\chocolatey\lib\Atom.0.136.0\tools\Atom\resources\app\node_modules\settings-view\lib\…:416
Error activating package config for “jshint” Error {code: "MODULE_NOT_FOUND", stack: (...), message: "Cannot find module 'emissary'"} c:\ProgramData\chocolatey\lib\Atom.0.136.0\tools\Atom\resources\app\node_modules\settings-view\lib\…:416
Error activating package config for “markdown-preview” Error {code: "MODULE_NOT_FOUND", stack: (...), message: "Cannot find module 'fs-plus'"} c:\ProgramData\chocolatey\lib\Atom.0.136.0\tools\Atom\resources\app\node_modules\settings-view\lib\…:416
Error activating package config for “Search” Error {code: "MODULE_NOT_FOUND", stack: (...), message: "Cannot find module 'open'"} c:\ProgramData\chocolatey\lib\Atom.0.136.0\tools\Atom\resources\app\node_modules\settings-view\lib\…:416
Error activating package config for “terminal-status” Error {code: "MODULE_NOT_FOUND", stack: (...), message: "Cannot find module 'domify'"} c:\ProgramData\chocolatey\lib\Atom.0.136.0\tools\Atom\resources\app\node_modules\settings-view\lib\…:416
Error activating package config for “todo-show” Error {code: "MODULE_NOT_FOUND", stack: (...), message: "Cannot find module 'fs-plus'"} c:\ProgramData\chocolatey\lib\Atom.0.136.0\tools\Atom\resources\app\node_modules\settings-view\lib\…:416
Error activating package config for “uglify” Error {code: "MODULE_NOT_FOUND", stack: (...), message: "Cannot find module 'uglify-js'"} c:\ProgramData\chocolatey\lib\Atom.0.136.0\tools\Atom\resources\app\node_modules\settings-view\lib\…:416
Uncaught Error: Cannot find module 'glob' 

I don’t know how to fix that.

I’m using Windows 7.


Sorry for my english…

If you need more information, tell me.


#2

I don’t have a lot of experience with the Windows command line, but in linux/mac, I would cd into the repo’s folder and run apm update. This should install the missing package dependecies (eg emissary).

Edit. Then restart atom for good measure.


#3

apm link used to just silently fail on Windows

I don’t know if that change has shipped yet, but it probably has, right? I mean, right?
That was fixed on 5th of September.


#4

If you look on the Releases page under v0.126.0 released on the 10th of September, you’ll see:

Fixed an issue where apm link would fail to work on Windows.

So yes, it has been fixed and released over a month ago.


#5

Oh yeah, I remember seeing that update message, now that you mention it.


#6

Link was created, but package and your dependencies not worked properly.

BUT, for some packages, like @dsandstrom said, run apm update fixed all package errors.

Anyway, I tried install the packages in other network without proxy, and not using apm link, just using apm install and works.


#7

Just install the “msysGit” on site “https://msysgit.github.io/#contribute” and restart the PC. Projects start install normally.


#8

I had a similar issue, and it turned out that apm needed a more up-to-date version of git than the one found in my path. The one installed with Atom was sufficient, but I had an older version that was being selected first.