Error: spawn flake8'linter-flake8': 'executablePath': '/usr/bin/flake8' ENOENT


#1

So I’m trying to trouble shoot this. I’m using linuxmint 18 sarah and want to use atom for python 3.5.2. I insalled python, followed the pip commands but used pip3 since I wanted to use python3.

I have a feeling my issue has something to do with PATH, but I’m so new to linux that I don’t really understand and most solutions i find, people seem to assume you know linux already… any help would be appreciated.

heres my error.

Error: spawn flake8’linter-flake8’: ‘executablePath’: ‘/usr/bin/flake8’ ENOENTError: spawn flake8’linter-flake8’: ‘executablePath’: ‘/usr/bin/flake8’ ENOENT at exports._errnoException (util.js:890:11) at Process.ChildProcess._handle.onexit (internal/child_process.js:182:32) at onErrorNT (internal/child_process.js:348:16) at _combinedTickCallback (internal/process/next_tick.js:74:11) at process._tickCallback (internal/process/next_tick.js:98:9)

edit: if I type which flake8 in terminal. It finds nothing.


#2

It sounds like you don’t have the flake8 utility installed. I suspect you’ll need to install it in order for the package to work. You should probably follow the instructions in the README since your modified version didn’t work out.