Error running apm install behind proxy


I am current trying to running apm install --check behind a corporate proxy to see if I have the build tools installed correctly. However I am getting the following error:

Checking for native build tools
      useStrictSsl = (_ref = this.npm.config.get('strict-ssl')) != null ? _ref
TypeError: Cannot read property 'config' of undefined
  at Install.module.exports.Install.installNode (C:\Users\chaines\AppData\Local\atom\app-0.177.0\resources\app\apm\lib\i
  at Install.installNode (C:\Users\chaines\AppData\Local\atom\app-0.177.0\resources\app\apm\lib\install.js:3:61)
  at Install.module.exports.Install.checkNativeBuildTools (C:\Users\chaines\AppData\Local\atom\app-0.177.0\resources\app
  at (C:\Users\chaines\AppData\Local\atom\app-0.177.0\resources\app\apm\lib\install.j
  at (C:\Users\chaines\AppData\Local\atom\app-0.177.0\resources\app\apm\lib\apm-cli.js:208:32)

  at Object.<anonymous> (C:\Users\chaines\AppData\Local\atom\app-0.177.0\resources\app\apm\lib\cli.js:6:7)
  at Object.<anonymous> (C:\Users\chaines\AppData\Local\atom\app-0.177.0\resources\app\apm\lib\cli.js:17:4)
  at Module._compile (module.js:456:26)
  at Object.Module._extensions..js (module.js:474:10)
  at Module.load (module.js:356:32)
  at Function.Module._load (module.js:312:12)
  at Function.Module.runMain (module.js:497:10)
  at startup (node.js:119:16)
  at node.js:929:3

My .apmrc looks like this (username, password and proxy have been masked but are correct in my config):


My apm config list

C:\Users\chaines>apm config list
; cli configs
globalconfig = "C:\\Users\\chaines\\AppData\\Local\\atom\\app-0.177.0\\resources\\app\\apm\\.apmrc"
user-agent = "npm/2.3.0 node/v0.10.35 win32 ia32"
userconfig = "C:\\Users\\chaines\\.atom\\.apmrc"

; userconfig C:\Users\chaines\.atom\.apmrc
https-proxy = "<MASKED>"
proxy = "<MASKED>"
strict-ssl = false

; globalconfig C:\Users\chaines\AppData\Local\atom\app-0.177.0\resources\app\apm\.apmrc
cache = "C:\\Users\\chaines\\.atom\\.apm"

; node bin location = C:\Users\chaines\AppData\Local\atom\app-0.177.0\resources\app\apm\bin\node.exe
; cwd = C:\Users\chaines
; HOME = C:\Users\chaines
; 'npm config ls -l' to show all defaults.

Due to the way my company firewall works https requests have to be routed over http. Anyone that can provide any help it would be awesome.


The version of npm used in 0.177.0 has a bug where it doesn’t respect things like strict-ssl. You can try upgrading npm to 2.5.1 or using the 0.175.0 version of Atom.


Is there a way to tell it to use my globally installed node and npm instead of the built in one? I couldn’t find a way to do that.


Does anyone know whether the npm issue has been fixed yet?


It has. It was fixed in 2.5.1. I already created an issue to have apm use the latest version, and it was completed. The next version of Atom should be fixed.


Thank you for fixing this.


v0.180.0 of Atom has been released:

It includes the update to v2.5.1 of npm. I’m going to close this topic as fixed in a week if there are no objections.


I just upgraded to 0.180.0 and still get the same error running apm install --check. I also uninstalled and completely reinstalled and still get the same error. Is there something I’m missing?


The Same problem here :frowning:

Version 0.181.0

Installing package ends with

Installing “minimap@4.2.3” failed.Hide output…gyp info it worked if it ends with ok
gyp info using node-gyp@1.0.2
gyp info using node@0.10.35 | win32 | ia32
gyp http GET
gyp WARN install got an error, rolling back install
Compiler tools not foundPackages that depend on modules that contain C/C++ code will fail to           install.Read here for instructions on installing Python and Visual Studio.Run apm install --check after    installing to test compiling a native module.

Running apm install --check outputs

C:\Users\mkrnac>apm install --check
Checking for native build tools
useStrictSsl = (_ref = this.npm.config.get(‘strict-ssl’)) != null ? _ref
TypeError: Cannot read property ‘config’ of undefined
at Install.module.exports.Install.installNode (c:\Users\mkrnac\AppData\Local\atom\app-0.181.0\resources\app\apm\lib\install.js:77:38)
at Install.installNode (c:\Users\mkrnac\AppData\Local\atom\app-0.181.0\resources\app\apm\lib\install.js:3:61)
at Install.module.exports.Install.checkNativeBuildTools (c:\Users\mkrnac\AppData\Local\atom\app-0.181.0\resources\app\apm\lib\install.js:559:19)
at (c:\Users\mkrnac\AppData\Local\atom\app-0.181.0\resources\app\apm\lib\install.js:724:21)
at (c:\Users\mkrnac\AppData\Local\atom\app-0.181.0\resources\app\apm\lib\apm-cli.js:209:32)
at Object. (c:\Users\mkrnac\AppData\Local\atom\app-0.181.0\resources\app\apm\lib\cli.js:6:7)
at Object. (c:\Users\mkrnac\AppData\Local\atom\app-0.181.0\resources\app\apm\lib\cli.js:17:4)
at Module._compile (module.js:456:26)
at Object.Module._extensions…js (module.js:474:10)
at Module.load (module.js:356:32)


I think npm is still not working for me in 0.182:

npm ERR! fatal: unable to connect to
npm ERR![0:]: errno=No such file or directory


You should check for open Issues on and either add your information to one already existing there or open a new one.


Thanks. An issue has now been opened:

That issue has now been closed but I don’t understand whether the bug has been validated and fixed. And, if fixed, when it will appear in a release. Please can someone explain the process?


This is a run down on how to tell if/when something is available:

According to the bug, it was fixed and is available in apm v0.141.0 which should be available in the next Atom release v0.183.0.

closed #14

This topic was automatically closed after 7 days. New replies are no longer allowed.