Error Publishing Package: "Creating new version failed: Requires authentication"


#1

I’m trying to publish a new version of a package. I used publish minor, and it worked up until the actual publishing step, at which point it failed with this message: Creating new version failed: Requires authentication.

I think this may have something to do with the fact that I change my username between now and the last time I published the package, but I don’t know how I am supposed to fix it. I would like the theme page to display the correct username (TheQZ), instead of my old one, ideally. Any ideas?

Many thanks!


#2

Have you done apm login after you changed your username?


#3

I did not, and that fixed it. I guess next time I should learn a bit more about the program itself. Thanks!


#4

Closing as resolved. Thanks!


#5