"error processing archive" Duing an installation attempt

When I attempt to install Atom in Ubuntu 18.04 I an error:

$ sudo apt-get install /home/stephen/Downloads/Atom.io/atom-amd64.deb
Reading package lists… Done
Building dependency tree
Reading state information… Done
Note, selecting ‘atom’ instead of ‘/home/stephen/Downloads/Atom.io/atom-amd64.deb’
The following additional packages will be installed:
git git-man gvfs-bin liberror-perl
Suggested packages:
gir1.2-gnomekeyring-1.0 git-daemon-run | git-daemon-sysvinit git-doc git-el
git-email git-gui gitk gitweb git-cvs git-mediawiki git-svn
The following NEW packages will be installed:
atom git git-man gvfs-bin liberror-perl
0 upgraded, 5 newly installed, 0 to remove and 0 not upgraded.
Need to get 4738 kB/95.2 MB of archives.
After this operation, 917 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Get:1us.archive.ubuntu.com/ubuntu bionic/main amd64 liberror-perl all 0.17025-1 [22.8 kB]
Get:2 us.archive.ubuntu.com/ubuntu bionic-updates/main amd64 git-man all 1:2.17.1-1ubuntu0.4 [803 kB]
Get:3 /us.archive.ubuntu.com/ubuntu bionic-updates/main amd64 git amd64 1:2.17.1-1ubuntu0.4 [3907 kB]
Get:4 /home/stephen/Downloads/Atom.io/atom-amd64.deb atom amd64 1.33.0 [90.4 MB]
Get:5 us.archive.ubuntu.com/ubuntu bionic-updates/main amd64 gvfs-bin amd64 1.36.1-0ubuntu1.1 [4692 B]
Fetched 4738 kB in 2s (3011 kB/s)
Selecting previously unselected package liberror-perl.
(Reading database … 292848 files and directories currently installed.)
Preparing to unpack …/liberror-perl_0.17025-1_all.deb …
Unpacking liberror-perl (0.17025-1) …
Selecting previously unselected package git-man.
Preparing to unpack …/git-man_1%3a2.17.1-1ubuntu0.4_all.deb …
Unpacking git-man (1:2.17.1-1ubuntu0.4) …
Selecting previously unselected package git.
Preparing to unpack …/git_1%3a2.17.1-1ubuntu0.4_amd64.deb …
Unpacking git (1:2.17.1-1ubuntu0.4) …
Selecting previously unselected package gvfs-bin.
Preparing to unpack …/gvfs-bin_1.36.1-0ubuntu1.1_amd64.deb …
Unpacking gvfs-bin (1.36.1-0ubuntu1.1) …
Selecting previously unselected package atom.
Preparing to unpack …/Atom.io/atom-amd64.deb …
Unpacking atom (1.33.0) …
dpkg: error processing archive /home/stephen/Downloads/Atom.io/atom-amd64.deb (–unpack):
trying to overwrite ‘/usr/bin/apm’, which is also in package apmd 3.2.2-15build1
Errors were encountered while processing:
/home/stephen/Downloads/Atom.io/atom-amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

What do I need to do to get his installed?

I just downloaded the latest .deb earlier and didn’t have any problems - maybe there was a problem with the download? Can you re-download and try again?

I did a second download of it as you suggested. When I attempted to install this I got the same result as I did with the first download.

Ahh sorry, looked at the output again and saw this:

Looks like you’re hitting this issue?

Yes, that is the same error. I is astonishing the Atom use the same name as an existing package, and that issue has not been fixed by now.

I am going to look into the ramifications of removing this conflicting package.

One of the solutions at the thread https://github.com/atom/atom/issues/3926 is to remove the apmd package. But I find a lot of dependencies on it:

~ apt-cache rdepends apm E: No packages found ~ apt-cache rdepends apmd
apmd
Reverse Depends:
libapm1
distributed-net
xapm
libapm-dev
alsa-base
|laptop-mode-tools
hdparm

The hdparm package description:

tune hard disk parameters for high performance

Get/set device parameters for Linux SATA/IDE drives.

Provides a command line interface to various kernel interfaces supported by

the Linux SATA/PATA/SAS "libata" subsystem and the older IDE driver subsystem.

Many newer (2008 and later) USB drive enclosures now also support "SAT"

(SCSI-ATA Command Translation) and therefore may also work with hdparm.

I am not sure I need this hdparm package.

The alsa-base package description:

Description-en: ALSA driver configuration files
This package contains various configuration files for
the ALSA drivers.
.
For ALSA to work on a system with a given sound card,
there must be an ALSA driver for that card in the kernel.
Linux 2.6 as shipped in linux-image packages contains
ALSA drivers for all supported sound cards in the form
of loadable modules. A custom alsa-modules package can
be built from the sources in the alsa-source package
using the m-a utility (included in the module-assistant
package). Please read the README.Debian file for more
information about loading and building modules.
.
ALSA is the Advanced Linux Sound Architecture.

So now I have to choose between an Atom installation, or having my speakers work. Is there another way? If I have to choose it is going to be to keep my speakers working.

My OS is Ubuntu 18.04