Error on launch "Failed to spawn command"


#1

When Atom opens the error comes up that says:

Failed to spawn command /Applications/Atom.app/Contents/Frameworks/Atom Helper.app/Contents/MacOS/Atom Helper. Make sure /Applications/Atom.app/Contents/Frameworks/Atom Helper.app/Contents/MacOS/Atom Helper is installed and on your PATH

And the chrome debugger comes up and says:

Uncaught BufferedProcessError: Failed to spawn command `/Applications/Atom.app/Contents/Frameworks/Atom Helper.app/Contents/MacOS/Atom Helper`. Make sure `/Applications/Atom.app/Contents/Frameworks/Atom Helper.app/Contents/MacOS/Atom Helper` is installed and on your PATH

When I go to the location of the Atom Helper executable and run it manually, I get a different error:

/Applications/Atom.app/Contents/Frameworks/Atom\ Helper.app/Contents/MacOS/Atom\ Helper ; exit;
module.js:330
    throw err;
          ^
Error: Cannot find module '/Applications/Atom.app/Contents/Frameworks/Atom Helper.app/Contents/Resources/atom.asar/browser/lib/init.js'
    at Function.Module._resolveFilename (module.js:328:15)
    at Function.Module._load (module.js:270:25)
    at Function.Module.runMain (module.js:493:10)
    at startup (node.js:120:16)
    at node.js:877:3
logout

#2

Could you give the following information?

  • Which version of Atom are you using?
  • What version of OS X are you running?
  • Did you install from the website or did you build Atom from source?
  • If you built from source did you follow the instructions?

#3

I am on version 0.199.0 of Atom, and i downloaded it from the website. Mac OS 10.10.4 (14E17e).

However, when I just opened it to check this, the error went away. I use open-last-project to make it remember what had last been opened, and every time I got that error it was trying to open a file that had been moved.


#4

Atom now has a feature built-in to remember what project was last opened. You might want to give it a try :grinning:


#5

I still get this error on 1.0.0. It only happens if you open Atom up into a blank window and then try to go to Preferences. If you have a project open you don’t get this error.

I get this on OSX 10.10.3


#6

If you’ve got a consistent repro, could you file a bug on https://github.com/atom/atom and then post a link to the bug in this topic?

Thanks!


#7

Bug filed: https://github.com/atom/atom/issues/7594