Error notification "language-hack package not found or deactivated but is required to provide support for Hack" Atom 1.0 OSX


#1

Hi!

I hope someone can tell me how to solve this:

Every time I open Atom, I get this error notification:
"[HACK] language-hack package not found or deactivated but is required to provide support for Hack"

https://www.evernote.com/l/AAkobbZ_ZyFObLXiuk7pIBn6-jVoQvtogUAB/image.png

Only I’m sure Hack is installed and updated:

https://www.evernote.com/l/AAk1_WqwEV9AapNlH3cyMyhcavf3So7LPiUB/image.png

I don’t know where the notification is coming from, I could uninstall Atom and install everything again, but I’d rather find out where the error is coming from and solve it, if possible.

Thanks for the help!


#2

Is the error logged in the console in the dev tools (ctrl+shift+i and then click the console tab)? If it is you can check the stack trace for the package that generated the error.


#3

The Atom-Hack package needs the language-hack package to work. You can install it from the command-line:

apm install language-hack

#4

Thanks @nounoursheureux!

For some reason I thought I had it installed…

That solved it.

(How can I close this thread?)


#5

Closing by request.


#6