Error message - how to get rid?


#1

Hi.

New Atom user here, my first question.

In my code, I’m getting repeat errors saying "Error. Special characters must be escaped [>]

I think that this is produced by the linter package I installed (which is great BTW).

Here is an example of a line causing this error. What is wrong with it and how can I correct the ‘error’? (the code seems to work perfectly)

<img class=“spiral” alt “spiral logo” src=images\lrg-spiral.png>

Thanks.


#2

I included code when I posted this on the wrong section. When I moved it, the code disappeared. The code is:

<img class="spiral" alt "spiral logo" src=images\lrg-spiral.png>

#3

For some reason my code is being removed. Lets try it in triple quotes

“”"<img class=“spiral” alt “spiral logo” src=images\lrg-spiral.png>"""


#4

You need to use triple backticks, see the Atom FAQ:


#5

You need quotes around the src and an equals sign after alt, like so:

<img class="spiral" alt="spiral logo" src="images\lrg-spiral.png">

#6

Thanks to you both. Your answer was correct, DamnedScholar - making those changes has removed the error. I can’t now remember where I found the syntax for that line of code.

leedohm, if I understand your post correctly (very steep learning curve being undertaken here) I need to wrap code in ``` characters when posting on this site?

Actually, how come DamedScholar saw my code but it wasn’t included in my post? Does it mean others can see it but not the original poster? Anyway, here is me trying to include DamedScholars correct code in this post:

<img class="spiral" alt="spiral logo" src="images\lrg-spiral.png">

Thanks again for all the help. More questions to follow no doubt.


#7

Discourse uses Github-Flavored Markdown for formatting tags, which supports single-` for inline code and triple-` for code blocks.

Actually, how come DamedScholar saw my code but it wasn’t included in my post?

It’s in the second post.


#8

You don’t need to, no, depending on what kind of code you’re posting. If you’re posting HTML, then yes because you can use limited HTML in the message box to do things like:

OMG WTH is this????

So if you want your raw HTML to show up, you should fence it in triple backticks like this:

OMG WTH is this????

``` ```

#9

Because I edited your second post to add the requisite triple-backticks :slight_smile:


#10

Thanks for that.


#11

Ahaa - that explains it! Thanks.