Error installing script@3.18.1 package


#1

I’ve been able to install atom-python-run and autocomplete-python through Atom, but when I try to install script@3.18.1 I get the following error below.
I just started using Atom, so no history other than above. I tried installing from both within Atom and from the command line using ‘apm install script’. I installed and ran Atom as an Administrator, but still no luck.
Note that no ‘npm-debug.log’ could be found because the directory under ‘Temp’ was never created.
Using Windows 7 (Windows_NT 6.1.7601); Atom version is 1.27.2 x64. I have git on my computer.

npm ERR! tar.unpack untar error C:\Users\neveuxp\AppData\Local\Temp\d-118431-9420-1oroz36.59dv89qkt9\package.tgz
npm ERR! addLocal Could not install C:\Users\neveuxp\AppData\Local\Temp\d-118431-9420-1oroz36.59dv89qkt9\package.tgz
npm ERR! Windows_NT 6.1.7601
npm ERR! argv “C:\Users\neveuxp\AppData\Local\atom\app-1.27.2\resources\app\apm\bin\node.exe” “C:\Users\neveuxp\AppData\Local\atom\app-1.27.2\resources\app\apm\node_modules\npm\bin\npm-cli.js” “–globalconfig” “C:\Users\neveuxp\.atom\.apm\.apmrc” “–userconfig” “C:\Users\neveuxp\.atom\.apmrc” “install” “C:\Users\neveuxp\AppData\Local\Temp\d-118431-9420-1oroz36.59dv89qkt9\package.tgz” “–runtime=electron” “–target=1.7.15” “–arch=x64” “–global-style”
npm ERR! node v6.9.5
npm ERR! npm v3.10.10
npm ERR! path C:\Users\neveuxp\AppData\Local\Temp\npm-10608-88894e8a\unpack-cbe614b8\examples\example.sage
npm ERR! code EPERM
npm ERR! errno -4048
npm ERR! syscall open

npm ERR! Error: EPERM: operation not permitted, open ‘C:\Users\neveuxp\AppData\Local\Temp\npm-10608-88894e8a\unpack-cbe614b8\examples\example.sage’
npm ERR! at Error (native)
npm ERR! { Error: EPERM: operation not permitted, open ‘C:\Users\neveuxp\AppData\Local\Temp\npm-10608-88894e8a\unpack-cbe614b8\examples\example.sage’
npm ERR! at Error (native)
npm ERR! errno: -4048,
npm ERR! code: ‘EPERM’,
npm ERR! syscall: ‘open’,
npm ERR! path: ‘C:\Users\neveuxp\AppData\Local\Temp\npm-10608-88894e8a\unpack-cbe614b8\examples\example.sage’ }
npm ERR!
npm ERR! Please try running this command again as root/Administrator.

npm ERR! Please include the following file with any support request:
npm ERR! C:\Users\neveuxp\AppData\Local\Temp\apm-install-dir-118431-9420-je9t1x.4l7iafw29\npm-debug.log


#2

I’ve seen similar errors reported on Windows where people had to disable their anti-virus temporarily to install packages - do you have any anti-virus running on your computer?


#3

Yes. I will try uninstalling McAffee then try again. Thanks!