Error installing linter-jshint

Hello,

I have looked over other errors people have posted about, but can’t seem to nail down this one issue. I had several other install problems that were rectified by deleting the .atom/ folder, and reinstalling everything. I have been able to install other linter plugins (html, css and php), but for some reason this one will not install. This is the error I keep getting:

Installing “linter-jshint@3.1.16” failed.Hide output…

npm WARN deprecated sb-memoize@1.0.2: No longer maintained - Use lodash probably
npm WARN enoent ENOENT: no such file or directory, open ‘C:\Users\XXXX\AppData\Local\Temp\apm-install-dir-11977-46672-1m51cw5.anum\package.json’
npm WARN apm-install-dir-11977-46672-1m51cw5.anum No description
npm WARN apm-install-dir-11977-46672-1m51cw5.anum No repository field.
npm WARN apm-install-dir-11977-46672-1m51cw5.anum No README data
npm WARN apm-install-dir-11977-46672-1m51cw5.anum No license field.

npm ERR! path C:\Users\XXXX\AppData\Local\Temp\apm-install-dir-11977-46672-1m51cw5.anum\node_modules\linter-jshint\node_modules\dom-serializer
npm ERR! code EBUSY
npm ERR! errno -4082
npm ERR! syscall rename
npm ERR! EBUSY: resource busy or locked, rename ‘C:\Users\XXXX\AppData\Local\Temp\apm-install-dir-11977-46672-1m51cw5.anum\node_modules\linter-jshint\node_modules\dom-serializer’ -> ‘C:\Users\XXXX\AppData\Local\Temp\apm-install-dir-11977-46672-1m51cw5.anum\node_modules\linter-jshint\node_modules.dom-serializer.DELETE’

npm ERR! A complete log of this run can be found in:
npm ERR! C:\Users\XXXX.atom.apm_logs\2019-08-07T15_05_31_135Z-debug.log

What can I do to properly install this plugin?

Thanks in advance to anyone that lends their assistance.

Did you try what is suggested in the error message?

The file C:\Users\XXXX\AppData\Local\Temp\apm-install-dir-11977-46672-1m51cw5.anum\node_modules\linter-jshint\node_modules\dom-serializer does not exist. I tried reinstalling right after posting the original message, and the same error kept coming up. I closed Atom and came back to it a few hours later, linter asked to install two additional components, which I allowed it to do. Tried to reinstall, and it worked perfectly. Perhaps it needed those additional components in order for jshint to work correctly?