Error installing Hydrogen


#1

I am trying to install Hydrogen in Atom (Windows) but getting the following error:

Installing “hydrogen@2.5.0” failed.Hide output…

canvas@1.6.11 install C:\Users\abhin\AppData\Local\Temp\apm-install-dir-11856-8580-1a6umv3.zdg0mp9zfr\node_modules\Hydrogen\node_modules\canvas
node-gyp rebuild
C:\Users\abhin\AppData\Local\Temp\apm-install-dir-11856-8580-1a6umv3.zdg0mp9zfr\node_modules\Hydrogen\node_modules\canvas>if not defined npm_config_node_gyp (node “C:\Users\abhin\AppData\Local\atom\app-1.27.2\resources\app\apm\node_modules\npm\bin\node-gyp-bin\…\node_modules\node-gyp\bin\node-gyp.js” rebuild ) else (node “C:\Users\abhin\AppData\Local\atom\app-1.27.2\resources\app\apm\bin\…\node_modules\node-gyp\bin\node-gyp.js” rebuild )
zeromq@4.6.0 install C:\Users\abhin\AppData\Local\Temp\apm-install-dir-11856-8580-1a6umv3.zdg0mp9zfr\node_modules\Hydrogen\node_modules\zeromq
node scripts/prebuild-install.js || (node scripts/preinstall.js && node-gyp rebuild)
prebuild-install WARN install unexpected end of file
Downloading libzmq for Windows
Download finished
C:\Users\abhin\AppData\Local\Temp\apm-install-dir-11856-8580-1a6umv3.zdg0mp9zfr\node_modules\Hydrogen\node_modules\zeromq>if not defined npm_config_node_gyp (node “C:\Users\abhin\AppData\Local\atom\app-1.27.2\resources\app\apm\node_modules\npm\bin\node-gyp-bin\…\node_modules\node-gyp\bin\node-gyp.js” rebuild ) else (node “C:\Users\abhin\AppData\Local\atom\app-1.27.2\resources\app\apm\bin\…\node_modules\node-gyp\bin\node-gyp.js” rebuild )
C:\Users\abhin\AppData\Local\Temp\apm-install-dir-11856-8580-1a6umv3.zdg0mp9zfr
`-- (empty)

gyp ERR! configure error
gyp ERR! stack Error: Python executable “C:\Program Files\Python36\python.EXE” is v3.6.5, which is not supported by gyp.
gyp ERR! stack You can pass the --python switch to point to Python >= v2.5.0 & < 3.0.0.
gyp ERR! stack at failPythonVersion (C:\Users\abhin\AppData\Local\atom\app-1.27.2\resources\app\apm\node_modules\node-gyp\lib\configure.js:454:14)
gyp ERR! stack at C:\Users\abhin\AppData\Local\atom\app-1.27.2\resources\app\apm\node_modules\node-gyp\lib\configure.js:443:9
gyp ERR! stack at ChildProcess.exithandler (child_process.js:197:7)
gyp ERR! stack at emitTwo (events.js:106:13)
gyp ERR! stack at ChildProcess.emit (events.js:191:7)
gyp ERR! stack at maybeClose (internal/child_process.js:877:16)
gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:226:5)
gyp ERR! System Windows_NT 10.0.17134
gyp ERR! command “C:\Users\abhin\AppData\Local\atom\app-1.27.2\resources\app\apm\bin\node.exe” “C:\Users\abhin\AppData\Local\atom\app-1.27.2\resources\app\apm\node_modules\node-gyp\bin\node-gyp.js” “rebuild”
gyp ERR! cwd C:\Users\abhin\AppData\Local\Temp\apm-install-dir-11856-8580-1a6umv3.zdg0mp9zfr\node_modules\Hydrogen\node_modules\canvas
gyp ERR! node -v v6.9.5
gyp ERR! node-gyp -v v3.4.0
gyp ERR! not ok
gyp ERR! configure error
gyp ERR! stack Error: Python executable “C:\Program Files\Python36\python.EXE” is v3.6.5, which is not supported by gyp.
gyp ERR! stack You can pass the --python switch to point to Python >= v2.5.0 & < 3.0.0.
gyp ERR! stack at failPythonVersion (C:\Users\abhin\AppData\Local\atom\app-1.27.2\resources\app\apm\node_modules\node-gyp\lib\configure.js:454:14)
gyp ERR! stack at C:\Users\abhin\AppData\Local\atom\app-1.27.2\resources\app\apm\node_modules\node-gyp\lib\configure.js:443:9
gyp ERR! stack at ChildProcess.exithandler (child_process.js:197:7)
gyp ERR! stack at emitTwo (events.js:106:13)
gyp ERR! stack at ChildProcess.emit (events.js:191:7)
gyp ERR! stack at maybeClose (internal/child_process.js:877:16)
gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:226:5)
gyp ERR! System Windows_NT 10.0.17134
gyp ERR! command “C:\Users\abhin\AppData\Local\atom\app-1.27.2\resources\app\apm\bin\node.exe” “C:\Users\abhin\AppData\Local\atom\app-1.27.2\resources\app\apm\node_modules\node-gyp\bin\node-gyp.js” “rebuild”
gyp ERR! cwd C:\Users\abhin\AppData\Local\Temp\apm-install-dir-11856-8580-1a6umv3.zdg0mp9zfr\node_modules\Hydrogen\node_modules\zeromq
gyp ERR! node -v v6.9.5
gyp ERR! node-gyp -v v3.4.0
gyp ERR! not ok
npm WARN enoent ENOENT: no such file or directory, open ‘C:\Users\abhin\AppData\Local\Temp\apm-install-dir-11856-8580-1a6umv3.zdg0mp9zfr\package.json’
npm WARN react-rangeslider@2.2.0 requires a peer of react@^0.14.0 || ^15.0.0 but none was installed.
npm WARN commonmark-react-renderer@4.3.4 requires a peer of commonmark@^0.27.0 || ^0.26.0 || ^0.24.0 but none was installed.
npm WARN apm-install-dir-11856-8580-1a6umv3.zdg0mp9zfr No description
npm WARN apm-install-dir-11856-8580-1a6umv3.zdg0mp9zfr No repository field.
npm WARN apm-install-dir-11856-8580-1a6umv3.zdg0mp9zfr No README data
npm WARN apm-install-dir-11856-8580-1a6umv3.zdg0mp9zfr No license field.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: canvas@1.6.11 (node_modules\Hydrogen\node_modules\canvas):
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: canvas@1.6.11 install: node-gyp rebuild
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: Exit status 1
npm ERR! Windows_NT 10.0.17134
npm ERR! argv “C:\Users\abhin\AppData\Local\atom\app-1.27.2\resources\app\apm\bin\node.exe” “C:\Users\abhin\AppData\Local\atom\app-1.27.2\resources\app\apm\node_modules\npm\bin\npm-cli.js” “–globalconfig” “C:\Users\abhin\.atom\.apm\.apmrc” “–userconfig” “C:\Users\abhin\.atom\.apmrc” “install” “C:\Users\abhin\AppData\Local\Temp\d-11856-8580-1mug0dw.hizj4qjjor\package.tgz” “–runtime=electron” “–target=1.7.15” “–arch=x64” “–global-style”
npm ERR! node v6.9.5
npm ERR! npm v3.10.10
npm ERR! code ELIFECYCLE

npm ERR! zeromq@4.6.0 install: node scripts/prebuild-install.js || (node scripts/preinstall.js && node-gyp rebuild)
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the zeromq@4.6.0 install script ‘node scripts/prebuild-install.js || (node scripts/preinstall.js && node-gyp rebuild)’.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the zeromq package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node scripts/prebuild-install.js || (node scripts/preinstall.js && node-gyp rebuild)
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs zeromq
npm ERR! Or if that isn’t available, you can get their info via:
npm ERR! npm owner ls zeromq
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR! C:\Users\abhin\AppData\Local\Temp\apm-install-dir-11856-8580-1a6umv3.zdg0mp9zfr\npm-debug.log


#2

Python needs to point to version 2.x . It’s currently finding 3.x

Don’t ask me why it can’t fix it itself.


#3

Will do it. Thanks