Error installing Atom: Couldn't write out staging user ID

I tried to install Atom and it won’t install. Below is the installer log.
https://gitlab.com/-/snippets/2026428

I tried to run it a second time and an error appeared saying

Installation has failed. Failed to extract installer

Hmm, I’m seeing mentions of GitKraken and Discord in the install logs, which is a bit odd.

Are you using the Atom installer from https://atom.io, or somewhere else?

I have two programs made with Electron installed on my computer, Discord and GitKraken.
Even so, that’s the log that Atom gave me when I used the Atom installer.
I downloaded the Insttaller from http://atom.io today.

I managed to open up %APPDATA%\Local\SquirrelTemp to find some more log files. The installer doesn’t tell the user to access these logs if the installation fails.
I have more logs now.

https://gitlab.com/-/snippets/2026591

I think I remember this bug. Sometimes a file is told to be deleted, but it won’t actually delete. Almost like it’s stuck half-way.

If I recall correctly, restarting the computer is the only thing that allowed the file to properly delete. It was gone by the time I could see the desktop boot up again.

Maybe restarting your computer then trying again to install will work?

(to be totally thorough: You can try deleting C:\Users\desbest\AppData\Local\atom, then restart, and if there is anything left there after restarting, try deleting C:\Users\desbest\AppData\Local\atom again after the restart. Then try installing Atom?)