ERROR: I got an error while building. Please help!


#1

While building I got this error:

spellchecker@1.0.1 install /home/debdut/atom/node_modules/spell-check/node_modules/spellchecker
node-gyp rebuild
gyp WARN EACCES user “root” does not have permission to access the dev dir "/root/.atom/.node->gyp/.node-gyp/0.18.0"
gyp WARN EACCES attempting to reinstall using temporary dev dir "/home/debdut/atom/node_modules/spell-check/node_modules/spellchecker/.node-gyp"
gyp WARN install got an error, rolling back install
gyp WARN install got an error, rolling back install
gyp ERR! configure error
gyp ERR! stack Error: 404 status code downloading tarball
gyp ERR! stack at Request. (/home/debdut/atom/apm/node_modules/atom-package-manager/node_modules/npm/node_modules/node-gyp/lib/install.js:230:14)
gyp ERR! stack at Request.emit (events.js:117:20)
gyp ERR! stack at Request.onResponse (/home/debdut/atom/apm/node_modules/atom-package-manager/node_modules/npm/node_modules/request/request.js:832:10)
gyp ERR! stack at ClientRequest.g (events.js:180:16)
gyp ERR! stack at ClientRequest.emit (events.js:95:17)
gyp ERR! stack at HTTPParser.parserOnIncomingClient (http.js:1692:21)
gyp ERR! stack at HTTPParser.parserOnHeadersComplete [as onHeadersComplete] (http.js:121:23)
gyp ERR! stack at Socket.socketOnData (http.js:1587:20)
gyp ERR! stack at TCP.onread (net.js:527:27)
gyp ERR! System Linux 3.2.0-4-686-pae
gyp ERR! command “node” “/home/debdut/atom/apm/node_modules/atom-package-manager/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js” "rebuild"
gyp ERR! cwd /home/debdut/atom/node_modules/spell-check/node_modules/spellchecker
gyp ERR! node -v v0.10.33
gyp ERR! node-gyp -v v0.12.2
gyp ERR! not ok
npm ERR! spellchecker@1.0.1 install: node-gyp rebuild
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the spellchecker@1.0.1 install script.
npm ERR! This is most likely a problem with the spellchecker package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node-gyp rebuild
npm ERR! You can get their info via:
npm ERR! npm owner ls spellchecker
npm ERR! There is likely additional logging output above.
npm ERR! System Linux 3.2.0-4-686-pae
npm ERR! command “/home/debdut/atom/apm/node_modules/atom-package-manager/bin/node” “/home/debdut/atom/apm/node_modules/atom-package-manager/node_modules/npm/bin/npm-cli.js” “–globalconfig” “/home/debdut/atom/apm/node_modules/atom-package-manager/.apmrc” “–userconfig” “/root/.atom/.apmrc” “install” “/root/.atom/.node-gyp/.atom/.apm/spell-check/0.44.0/package.tgz” “–target=0.18.0” “–arch=ia32” "–quiet"
npm ERR! cwd /home/debdut/atom
npm ERR! node -v v0.10.33
npm ERR! npm -v 1.4.4
npm ERR! code ELIFECYCLE
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR! /home/debdut/atom/npm-debug.log
npm ERR! not ok code 0


#2

From first glance it seems that you can permission problems. Have you tried to run this as sudo? PS: more information about what exactly were you doing(building what exactly, what OS) might help.


#3

Hello, my OS is Debian 7.6 Wheezy i386. I did use this command under sudo. I was building Atom as per the guide for Debian in the website. Please help! The last command I typed:

sudo script/build

It was going fine , installing packages, until installing spell-checker package.


#4

You shouldn’t run the build step under sudo, only the install step needs it.

You’ll probably have to fix the permissions and run the build again without sudo.

$ chown -R debdut:debdut ~/{.atom,atom}
$ cd ~/atom
$ script/build
$ sudo script/grunt install

This should be all you need.


#5

Actually its not done! When I install it I get a link "atom’ in LXDE menu, I click it nothing happens.
I type in command line but I get this instead:

debdut@debdut:~/atom$ atom
debdut@debdut:~/atom$ /usr/local/share/atom/atom: /lib/i386-linux-gnu/i686/cmov/libc.so.6: version `GLIBC_2.15’ not found (required by /usr/local/share/atom/libgcrypt.so.11)


Issues Installing on Fedora
#6

It looks your problem is different, you don’t have GLIBC 2.15 installed. Similar to: Issues Installing on Fedora

Edit: Looking at that issue, you will probably need at least 2.17 installed.