Error during build for OSX


#1

Hi Guys,

Who can help me out? I’m really stuck on building my app for Mac OSX.

I tried to use the method found here: http://electron.rocks/electron-angular-packing-and-distribution/

This is the error I recieved:
MacBook-Pro-van-Bauke:Evado App Bauke$ npm run build:osx

evado@0.1.0 build:osx /Users/Bauke/Desktop/Evado App
npm run pack:osx && electron-builder “dist/osx/Evado-darwin-x64/Evado.app” --platform=osx --out=“dist/osx” --config=builder.json

evado@0.1.0 pack:osx /Users/Bauke/Desktop/Evado App
npm run clean:osx && electron-packager . “Evado” --out=dist/osx --platform=darwin --arch=x64 --version=0.36.2 --icon=assets/osx/logo.icns --ignore=dist --ignore=assets --ignore=builder.json --ignore=bower.json --ignore=README.md --ignore=.gitignore --ignore=preview.png

evado@0.1.0 clean:osx /Users/Bauke/Desktop/Evado App
rm -rf ./dist/osx

Packaging app for platform darwin x64 using electron v0.36.2
Wrote new app to dist/osx/Evado-darwin-x64
sh: electron-builder: command not found

npm ERR! Darwin 16.0.0
npm ERR! argv “/usr/local/bin/node” “/usr/local/bin/npm” “run” "build:osx"
npm ERR! node v6.8.1
npm ERR! npm v3.10.8
npm ERR! file sh
npm ERR! code ELIFECYCLE
npm ERR! errno ENOENT
npm ERR! syscall spawn
npm ERR! evado@0.1.0 build:osx: npm run pack:osx && electron-builder "dist/osx/Evado-darwin-x64/Evado.app" --platform=osx --out="dist/osx" --config=builder.json
npm ERR! spawn ENOENT
npm ERR!
npm ERR! Failed at the evado@0.1.0 build:osx script ‘npm run pack:osx && electron-builder “dist/osx/Evado-darwin-x64/Evado.app” --platform=osx --out=“dist/osx” --config=builder.json’.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the evado package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! npm run pack:osx && electron-builder “dist/osx/Evado-darwin-x64/Evado.app” --platform=osx --out=“dist/osx” --config=builder.json
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs evado
npm ERR! Or if that isn’t available, you can get their info via:
npm ERR! npm owner ls evado
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR! /Users/Bauke/Desktop/Evado App/npm-debug.log


#2

I have solved the problem myself. Seems like I had the npm electron installed in my app folder, but not in my development folder.