error : cannot spawn git or cannot spawn ssh


#1

Dear,
I’m new to Atom (I used to use giteye before) and try to connect it to our companies git repository.

the repository is available at something like :
ssh://gitserver.company.com/Location/Of/Project
authentication is done with ssh key

versions used :
Atom : 1.24.1
Electron: 1.6.16
Chrome : 56.0.2924.87
Node : 7.4.0
OS is windows 10

After installing Atom, I opened the project folder of my giteye project, which worked fine.

When trying to pull from the repository, I get this error :
“error: cannot spawn git: No such file or directory”
When trying to push to the repository, I get this error :
“error: cannot spawn ssh: No such file or directory. fatal: unable to fork”

I’m sure I’m missing something obvious, like a missing git- or ssh-setting or package, …
I looked trough the preferences but couldn’t find a setting related to the ssh-connection or authentication keys.
I also tried searching for the above error messages but couldn’t find any related help.

Thanks in advance for your help,
Koen.


#2

I have the same error setting.

Initially I could push and pull from my repositories, now it throws the error

" error: cannot spawn ssh: No such file or directory

fatal: unable to fork"

This happened without me changing anything that I know of. Git Bash (Git for Windows) still works for the same repositories. Is there anyone that knows more? It seems to be a relatively uncommon error for other integrated git clients but none of the threads have a clear solution that can be applied to this problem in atom.


#3

How are you connecting to the server? If it’s through ssh, it’s not purely through git.


#4

I’m connecting to GitLab: git@gitlab.com:<repository.git>.

I think that uses SSH.


#5

I also have a 2nd installation of Atom that is catered to the julia language, Juno. Where the git sidebar still works fine, even for the same repository.


#6

This is important information. What’s different between the two instances of the editor? Tell me everything.


#7

I wouldn’t know. The first Atom installation is a fresh out of the box 1.30.0, and Juno is version 1.23.3. I haven’t installed any packages, changed any settings, nothing at all. You could install and compare the two. I don’t know how to find the information you are looking for.

Reinstalling Atom and deleting the .atom folder had no effect.


#8

Start with how you installed them. You must have done something special, because the normal means of setting up Juno is to install Atom normally and then install the uber-juno package. If you have two different installations of Atom with different .atom/ folders, that’s something you can talk about.

I don’t know how to find the information you are looking for.

It’s probably right in front of you. Tell me about the Atom versions. The Juno instance is 1.23.3, because that’s what you installed when you set that up, and it’s not the “real” installation (in AppData/Local/atom) because it’s not updating automatically. The main one is 1.30.0. You used to be able to use git in these repositories in the main Atom, then it stopped. Is that maybe because of the update? When did it stop? You could download and try an older version of Atom to see if it’s specific to 1.30.0.


#9

The Juno installation is older, I somehow downloaded it as is, without first installing Atom, through software called JuliaPro I believe. The executable that is run for Juno is “X:\JuliaPro\app-1.23.3\atom.exe”.

I just now tried deleting the AppData folder that you mentioned because some files persisted after an uninstall but that didn’t help.

I’ve had this install of Atom for a few days only, it worked up until today for several commits, I even made several commits today, and only 10 minutes after the last succesful push it suddenly broke when someone else made a commit and I had to pull before I could push. But I’d find it hard to believe that it would be connected to that.


#10

What happens if you manually install a lower version of Atom? Just download one from the GitHub releases page I linked, unzip it into a folder, and run atom.exe. It will use your normal .atom/, unless you configure it like I assume the JuliaPro distro is with a custom .atom/ next to the application folder. You don’t have to mess with AppData/Local/atom/ at all to try out other versions.


#11

It doesn’t work in Atom 1.29.0 either but it does in Atom 1.20.0, I’ll stick to that version for now unless you have any ideas for a fix?


#12

I haven’t a clue, and we’d need to find the exact version of Atom where things change before we could look for the source of the issue.