Error after run 'apm'


#1

After run ‘apm’ I get this:

$ apm

/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/node_modules/keytar/node_modules/bindings/bindings.js:83
        throw e
              ^
Error: Module version mismatch. Expected 13, got 11.
    at Module.load (module.js:349:32)
    at Function.Module._load (module.js:305:12)
    at Module.require (module.js:357:17)
    at require (module.js:373:17)
    at bindings (/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/node_modules/keytar/node_modules/bindings/bindings.js:76:44)
    at Object.<anonymous> (/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/node_modules/keytar/lib/keytar.js:4:31)
    at Object.<anonymous> (/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/node_modules/keytar/lib/keytar.js:58:4)
    at Module._compile (module.js:449:26)
    at Object.Module._extensions..js (module.js:467:10)
    at Module.load (module.js:349:32)

I try to update manually the bindings in node_modules of keytar, but this didn’t work.
Does anyone know how to solve it? Thanks!


#2

i think i ran “sudo npm install -g n” and that solved it


#3

Yes @JvdMeulen, but I had already the n installed globally. The problem is the version of node I run, it’s 0.11.10 and I change to 0.10.24 (using n) and I managed to solve.

Thanks :wink: