Error after Renaming a Theme


#1

I tried to rename my Broadcast color scheme from https://atom.io/themes/broadcast-theme to https://atom.io/themes/broadcast-color-scheme. Though, instead of updating the existing package it created a new one? Is this expected behaviour?

This is how I renamed it.

$ apm publish --rename broadcast-color-scheme --tag v1.1.1
Renaming broadcast-theme to broadcast-color-scheme ✓
Preparing and tagging a new version ✓
Pushing v1.1.1 tag ✓
Publishing broadcast-color-scheme@v1.1.1 ✗

Since the publishing didn’t work I tried to publish it again.

$ apm publish --tag v1.1.1
Publishing broadcast-color-scheme@v1.1.1 ✓

#2

It looks like everything worked properly:

Renaming broadcast-theme to broadcast-color-scheme ✓

As far as I can tell, the old name remains there, but it points to the new repository. This prevents people who might have downloaded it before from being dropped.


#3

Okay, I thought it would just rename the package. Though, when I’m searching for the package it shows up twice. Is this also expected behaviour?


#4

As far as I know, yes. Have you tried installing the old one and see if you get the new one instead?


#5

When I install the old one it is named as before and I now have two versions of the color scheme installed. One called Broadcast and one called Broadcast Color Scheme.


#6

cc @thedaniel … thoughts?


#7

Any updates on this?


#8

I reverted the repo and renamed it to its previous name. How do I delete the new one? https://atom.io/themes/broadcast-color-scheme


#9

Open a bug on atom/apm and cc @thedaniel.


#10

Okay. Done. https://github.com/atom/apm/issues/269