Error after packaging the app with electron-packager


#1

I’m new to Electron, and I really love it so far, but I’m unable to package any of mine apps, at first I thought that it’s maybe something related to my code, then I download “https://github.com/atom/electron-quick-start” run npm install and then I run “electron-packager . FooBar --platform=darwin --arch=x64 --version=0.28.2” it build the app but when I try to open it I get so I didn’t touch any code from the example, just wanted to build it and I got an error, what am I doing wrong? Thanks!


#2

The electron module wasn’t available until sometime around 0.35 or 0.36. Previously, you would require individual modules. After 0.35-0.36 everything was moved under the single electron module. So, you could change your require statements or, when specifying version for electron-paclager, use a newer version