EPERM: operation not permitted, read

Unable to install all packages…
Permission error occur when I install the packages…

EPERM: operation not permitted, read in C:\Users\CDT-17-10024.atom\packages\gpp-compiler\package.json
Hide Stack Trace
Error: EPERM: operation not permitted, read
at Object.fs.readSync (fs.js:675:18)
at tryReadSync (fs.js:540:20)
at Proxy.fs.readFileSync (fs.js:575:19)
at Proxy.fs.readFileSync (ELECTRON_ASAR.js:538:29)
at Object.readFileSync (C:\Users\CDT-17-10024\AppData\Local\atom\app-1.34.0\resources\app\static<embedded>:11:580367)
at PackageManager.loadPackageMetadata (C:\Users\CDT-17-10024\AppData\Local\atom\app-1.34.0\resources\app\static<embedded>:11:385523)
at PackageManager.loadAvailablePackage (C:\Users\CDT-17-10024\AppData\Local\atom\app-1.34.0\resources\app\static<embedded>:11:380504)
at PackageManager.loadPackage (C:\Users\CDT-17-10024\AppData\Local\atom\app-1.34.0\resources\app\static<embedded>:11:380013)
at PackageManager.activatePackage (C:\Users\CDT-17-10024\AppData\Local\atom\app-1.34.0\resources\app\static<embedded>:11:382517)
at C:\Users\CDT-17-10024\AppData\Local\atom\app-1.34.0\resources\app\static<embedded>:11:899185
at r (C:\Users\CDT-17-10024\AppData\Local\atom\app-1.34.0\resources\app\static<embedded>:11:893791)
at o (C:\Users\CDT-17-10024\AppData\Local\atom\app-1.34.0\resources\app\static<embedded>:14:1032547)
at ChildProcess.n.process.on.e (C:\Users\CDT-17-10024\AppData\Local\atom\app-1.34.0\resources\app\static<embedded>:14:1032753)
at emitTwo (events.js:126:13)
at ChildProcess.emit (events.js:214:7)
at Process.ChildProcess._handle.onexit (internal/child_process.js:198:12)
at C:\Users\CDT-17-10024.atom\packages\gpp-compiler\package.json:1:1

Did you install or run Atom with admin permissions at any point?

I just reinstalled atom with admin permissions, but it dosen’t work…
I have no idea…

When someone asks you a question without giving you an instruction, please answer the question and don’t read any instructions into it. I know that some people will get onto you for not reading their minds and knowing that their questions were meant as implicit instructions, but I assure you that I will never do that to you. :slight_smile:

I don’t actually know if installing Atom with admin permissions hurts anything on Windows. What does cause problems is if it is running as admin when it writes, for example, the .atom/ folder, which it does the first time it runs. That would be a reason for you to not be able to read that folder later, when you’re working without admin permissions. The solution is probably to delete .atom/ and let Atom rebuild it without heightened permissions.

Thanks for the support!
I installed Atom without admin permissions at first and error occurs. So I got it wrong…

I just tried that but it still doesn’t work.

And also I delete .atom/, AppData/Local/atom and AppData/Roaming/Atom and reinstall Atom before issue the topic but it doesn’t work too.

Major weird. I don’t see anything else that jumps out at me except that CDT-17-10024 is a really weird user name and feels like it might be computer generated. But if Atom is installed under the same user who runs it, that shouldn’t be relevant.

What happens if you use apm install gpp-compiler from the command line?