Ensure Single Trailing Newline not working?


#1

I have “Ensure Single Trailing Newline” checked
and Cmd-S is still deleting my trailing newline at the bottom of my files.

I also happen to be in Vim-mode for what it’s worth.
Is anyone else seeing this issue?


Strip trailing whitespace option
#2

Have you tried using atom --safe? This will disable all non-default packages and allow you to see if one of your other packages is conflicting.