Empty package folders after failed update


#1

For some reason many packages were not updated in my last update attempt, there were some errors, that I do not remember now. But after that when I open atom, many packages that i had, and that tried to be updated and failed that time, are no longer working. If I go to installed package list there are many packages that do not have any icon or description:

And when I go to package folder, for example to the same “atom-alignment” - the folder exists, but it is empty!

Well how do I fix that? Is the only way now to manually install them all??

I have already tried apm update, apm upgrade without any luck.


#2

I’ve run into this as well, and so far the best solution I’ve found is to Uninstall. Then after the uninstall finishes (should be quick…because there’s nothing left), the button should change back to an Install. Package settings are preserved.


#3

I’ve also been running into this issue pretty frequently when trying to update packages, and like @Wliu suggested, the best solution at that point is to uninstall/reinstall the package.
Though, I’ve also found a workaround for this issue seems to be temporarily disabling the package before updating, and then re-enabling it once the update is complete.
Hope it helps!