Emmet won't allow me to create new lines


#1

The Emmet package’s keybindings have been causing me grief the past couple days. I had no use for its reflect-css-value keybinding of shift-cmd-r, and I’ve always used that for re-indenting. After doing a clean install of Yosemite and re-installing Atom and my packages, that stopped working. The solution was to add this to my keymap.cson:

'.platform-darwin .editor:not(.mini)':
  'shift-cmd-R': 'native!'
  'shift-cmd-r': 'editor:auto-indent'

I thought the same solution might work for this new lines problem. Nothing happens when I hit return/enter. So I tried this in my keymap:

'.pane .editor:not(.mini)':
  'enter': 'native!'

This doesn’t fix the problem for me, though. Hitting return/enter still does nothing. I also tried using unset!, but it didn’t work (didn’t expect it to).


Enter & Tab keys aren't working. What should I do?
Unbind plugin keybinding
#2

See the following issues for more information:

This issue mentions why Emmet is breaking in this way:

I think the only solution right now is to disable Emmet until emmetio/emmet-atom#155 is taken care of.


0.144.0 OS X return key
#3

I had the same problem, please go to packages on the preferences view and update Emmet, for me just work.

See this https://github.com/atom/atom/issues/3970#issuecomment-60523049


#4

haha, I can create new lines now, but now the tab key doesn’t work!

Edit: I can tab for autocomplete, but I can’t insert (soft) tabs.


#5

Emmet has been nothing but broken on Atom. After using it for so long in Sublime, it’s disappointing. I wonder why it never seems to work properly in Atom?


#6

I didn’t have any problems til I performed a clean install with Yosemite. Hopefully things get resolved soon. Definitely slows me down not being able to use Emmet.


#7

Updating the package works for me.


#8

downgrading works for me. I saw someone who was having the same problem mention that 0.9.0 works fine for them, so I tried downgrading to it and it works. sticking with it for now.


#10

Yeah, just update the package!