Emmet Incrementing Number by .2


#1

I’m trying to make it so I can increment numbers by 1 when hitting alt + up, but for some reason my numbers are being incremented by .2. This is what my keymap.cson file looks like:

'alt-up': 'emmet:increment-number-by-1'
'alt-down': 'emmet:decrement-number-by-1'

Any help with this is appreciated.

Thanks in advance!


#2

I don’t think that’s needed in keymap.cson, since the key combo is native to Emmet. I bet it is happening twice each time, once native to emmet, once to satisfy your keymap.

Try using command-period to bring up the key resolver and try the combo. see if emmet happens twice.

I just tried it without your keymap setting, and it works fine.


#3

@smlombardi That combo seems to be calling another from inc-dec-value. Even though I’ve uninstalled that package.


#4

Have you restarted/reloaded Atom since uninstalling the package? Many packages fail to clean up after themselves and keep listening for commands even after disabling/uninstalling.


#5

Restarted Atom and it’s still incrementing in 0.1 increments.


#6

Any help on this issue? Still having the same problem.