Electron support for different versions of openSUSE


#1

I see the following are listed as supported Linux variants:

  • Ubuntu 12.04 and later
  • Fedora 21
  • Debian 8

However, I would like to use electorn on SUSE 11SP4 because my workplace uses this version (I know it’s old :frowning: )
I also don’t have sudo on my system.

The atom build doc https://github.com/atom/atom/blob/master/docs/build-instructions/linux.md has the following line for openSUSE so it seems electron could work for openSUSE:

sudo zypper install nodejs nodejs-devel make gcc gcc-c++ glibc-devel git-core libgnome-keyring-devel rpmdevtools libX11-devel libxkbfile-devel

If I download electron 1.4.6 and run electron I get the following error about glibc_2.12:

…/nodejs/v7.0.0/lib/node_modules/electron/dist/electron: /lib64/libpthread.so.0: version `GLIBC_2.12’ not found (required by …/nodejs/v7.0.0/lib/node_modules/electron/dist/electron)

This leads me to believe that at a minimum openSUSE 12 would be needed. The openSUSE 11SP4 default glibc version is 2.11.3 :unamused:

Does anyone have experience trying to get electron working for openSUSE 11? I can think of a few options however I would like to know if anyone has experience with them:

  • Compile electron on a newer version such as openSUSE 12 and then bundle the dependent shared libs into a subdir under for my Web App. Refer to the shared libs using the LD_LIBRARY_PATH env var

  • Compile a newer glibc (and it’s required dependents hopefully not too many :frowning: ) on the openSUSE 11 system. Still would need to put these shared libs into a dir refered to by LD_LIBRARY_PATH


#2

Hi, did you resolved this?