Electron is severely crashing Windows


#1

Hi,

I asked the question on Stack Overflow but I figured I might as well ask here (http://stackoverflow.com/questions/31548012/electron-atom-shell-severely-crashes-windows).

Please refer to the Stack Overflow post linked above for the images as I cannot post them here as a new user…

I am writing an application and running it with Electron. As I am testing and debugging things, I start my application (electron.exe) and close it every so often (sometimes maybe once or twice per minute).

After a (seemingly random and definitely not related to code change) while, the following errors appear right when starting the application:

[img - view on SO]

At this point, the application flashes one time when open but then runs normally.

Usually not very long after, starting the application results in the errors below:

[img - view on SO]

At this point, the application is frozen for a few seconds when opening and then runs apparently slower than usual. As soon as this starts to happen, it is also impossible to open a browser page (tested Chrome and IE) - page remains blank and process seems to hang:

[img - view on SO]

The worst is that at this point, Windows will not shut down properly. Trying to sign out or shutdown results in a blue screen with the cursor stuck with the “loading” icon forever. The only solution from there is to force the computer to shut down by holding the power button. When doing this, I had about 50% chance of having Windows stuck in an infinite repair loop, with no other choice than to do a system restore.

So now I learned that I must reboot Windows as soon as those GL_INVALID_OPERATION happen…

Would that be an issue with my computer in particular (I am not able to test on another computer for another 2 weeks) or something with Electron?

Also, on a side note, maybe related or maybe not, sometimes the application seems to start 2 Renderer processes instead of 1 - at least the logs show the “Renderer process started” twice.

Thanks


#2

Mmmh… Already tried updating graphics drivers? If so, nave you tried running the app in windows’ safe mode so that the drivers are disabled?

Anyway, that’s some hardcore graceful error handling over there!! :smiley:


#3

Drivers are up-to-date ; haven’t tried safe mode yet, will give it a try.