Electron-forge: Use different version of electron-prebuilt-compile other than 1.6.11


#1

I am trying to use different version of electron-prebuilt-compile with electron-forge project which has chrome version 51. So I am doing npm uninstall first version of electron-prebuilt-compile (1.6.11) and npm install second version (e.g. 1.2.6) in project directory. I see below error message

Debugging with legacy protocol because a runtime executable is set.
electron-forge-vscode-win.cmd --debug-brk=20173
× Locating Application
Electron forge was terminated:
You must depend on an EXACT version of “electron-prebuilt-compile” not a range

my package.json file is attached here

{
  "name": "test-workstation",
  "productName": "test-workstation",
  "version": "1.0.0",
  "description": "My Electron application description",
  "main": "src/index.js",
  "scripts": {
    "start": "electron-forge start",
    "package": "electron-forge package",
    "make": "electron-forge make",
    "lint": "eslint src"
  },
  "keywords": [],
  "author": "",
  "license": "MIT",
  "config": {
    "forge": {
      "make_targets": {
        "win32": [
          "squirrel"
        ],
        "darwin": [
          "zip"
        ],
        "linux": [
          "deb",
          "rpm"
        ]
      },
      "electronPackagerConfig": {},
      "electronWinstallerConfig": {
        "name": "test_workstation",
        "loadingGif": "build/install-spinner.gif",
        "iconUrl": "validurl"
      },
      "electronInstallerDebian": {},
      "electronInstallerRedhat": {},
      "github_repository": {
        "owner": "",
        "name": ""
      },
      "windowsStoreConfig": {
        "packageName": "",
        "name": "testworkstation"
      }
    }
  },
  "dependencies": {
    "electron-compile": "^6.4.1",
    "appdirectory": "^0.1.0",
    "async": "^2.0.1",
    "chromium-net-errors": "^1.0.3",
    "is-reachable": "^1.3.0",
    "winston": "^2.2.0"
  },
  "devDependencies": {
    "babel-plugin-transform-async-to-generator": "^6.24.1",
    "babel-preset-env": "^1.5.1",
    "babel-preset-react": "^6.24.1",
    "electron-prebuilt-compile": "^1.6.11",
    "eslint": "^3.19.0",
    "eslint-config-airbnb": "^15.0.1",
    "eslint-plugin-import": "^2.3.0",
    "eslint-plugin-jsx-a11y": "^3.0.2",
    "eslint-plugin-react": "^7.0.1"
  }
}

is there any documentation for this?