Electron command does nothing


#1

I cloned the prebuilt quickstart for electron and that worked fine. I was trying to import the remote module, but then started getting token errors (things like “missing token: >”) that were inside the remote library. Looking around on the web it seemed like I need to rebuild the electron module, so I modified the libraries to use the actual electron package, but now when I run the “electron” command instead of “npm start” on my directory I get no window and no output.

electron .

I’ve also tried “npm start”, but that complains about app being undefined.

const electron = require(‘electron’);
const app = electron.app;
app.on(…) // app is undefined here


Can't run the quick start demo?
#2

hi,

I had the same problem using electron 0.35.0.

test this:

const electron = require(‘electron’);
const remote = electron.remote;
const app = remote.app;

console.log(app);


#3

If you’re using electron globally, I would run npm install -g electron again. If you’re using it in your local directory I would delete the node_modules folder completely, restore the npm install command in your package.json file from the electron quick start one, and then run npm install in your the root of your app.